Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My mouse is so sensitive that it randomly wakes my computer up even when I don't touch the mouse. I don't want this to happen, so I want to disable the mouse's ability to wake the computer.

I know it's the mouse waking the computer because I ran powercfg -lastwake.

So I've tried this:

  1. Click Start.
  2. Type "cmd" into the Search box.
  3. Press Ctrl+Shift+Enter
  4. Click "Run as Administrator".
  5. Type the following command and press Enter: powercfg -devicedisablewake "HID-compliant mouse"

I get this error:

You do not have permission to enable or disable device wake.

So instead I go into Device Manager > Mice and other pointing devices > HID-compliant mouse and uncheck the box (within the mouse configuration) that says Allow this device to wake the computer.

When I run powercfg -devicequery wake_armed, nothing appears, which is good.

So for a while, the next few sleep sessions are fine, and the mouse doesn't wake the computer.

But then eventually something rechecks that checkbox (Allow this device to wake the computer) and so my ultra-sensitive mouse starts waking the computer from sleep all the time*. I can't seem to get the checkbox to stay empty. Any ideas?

P.S. I have a Microsoft Natural Wireless Laser Mouse 7000 and a computer running Windows 7.

share|improve this question
4  
I have absolutely no idea what it causing your problem, but I feel the need to let you know that this was one of the most well-constructed questions I've seen on StackExchange lately. –  Hyppy Apr 2 '11 at 3:34
    
I would just turn the mouse off if it has on/off switch which most of wireless mice have. –  tumchaaditya Aug 14 at 20:31
    
Unfortunately this is not windows 98 or XP anymore, when you set an option and it does just that. Now all kind of smarty-pants applications interfere with same device, every single option I set in windows 7 is unreliable. –  adrianTNT Aug 16 at 11:00

5 Answers 5

This may work, reboot and go to your bios.
In the BIOS/cmos -Power Management Setup- section will be a list of actions that will start your machine network, mouse power on, keyboard power on, etc-move the mouse setting to disabled.

Hope this fixes it to your requirements.

share|improve this answer

Low tech solution: Put the mouse upside down on your table when its not in use. This prevents the optics from detecting any movement.

share|improve this answer
    
This is a hilariously clever solution. I've done this before, although having the bright light from the mouse shining around can be annoying when you aren't using the computer. It's also a bit of an annoyance to have to remember to do this, but hey, it's definitely one solution! –  nhinkle Apr 2 '11 at 19:37
    
It seems like the solution to “having the bright light from the mouse shining around” might be to put a dark cloth over it. Which makes me wonder whether you might be able to get the same effect by putting the mouse, right-side-up, on a dark cloth. Ideally something thick (like felt), so it would absorb any vibrations. –  Scott Sep 9 at 18:49
  1. Go into Device Manager (use Search to find it)
  2. Find your mouse under "Mice and other pointing devices"
  3. Right-click it and choose Properties
  4. Go to the Power Management tab
  5. Untick the "Allow this device to wake the computer" checkbox.
  6. Click OK.
share|improve this answer

UAC settings keeping changes from sticking? You are administrator? Try setting it from safe mode. Turn off automatic updates at least for the mouse.

Use GUI instead of CLI: Change Advanced Power Settings, USB settings: disable "allow to wake" for the mouse.

Do you use CCleaner or the like? It could be erasing some settings.

share|improve this answer

Try adding the number displayed along with the device; powercfg -devicedisablewake "HID-compliant mouse (006)" instead. I've also found some devices which support both a mouse and keyboard need to have both device types disabled (i.e., if "keyboard" is enabled, the mouse still wakes the computer).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.