Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I had Windows 7 installed on my system for a few months. But I started having some problems while connecting to internet. I got my hands on Ubuntu Ultimate, so I tried linux for last one month or so.

Now I want to go back to good old Windows XP. I have an installation CD which I had tried previously. But now when I try to install the first part of installation goes without any trouble. The one where you accept licence agreement, format partition and all file copy. Problem comes after file copy is complete. System is restarted to boot from hard disk but it never starts.

Only thing displayed is "DISK ERROR". And after I press enter it shows

DISK BOOT FAILURE. INSERT SYSTEM DISK AND PRESS ENTER
share|improve this question
add comment

2 Answers

could there be a bad sector in your hard drive? try to do a disk check if your bios has this feature. else you should download the drive check software from your hard drive manufacturer to check.

share|improve this answer
    
From some research i did on net, All i came to understand that Ubuntu might have disturbed my MBR. I tried doing "bootrec" in XP recovery console but it says the commandis not supported!! –  Rohan210 Apr 2 '11 at 5:34
    
hey, I think the command in XP recovery console should be 'fixboot' without the quotes or you could try what was mentioned by Matt Jenkins –  szeli Apr 5 '11 at 1:42
add comment

It sounds like Windows has failed to install the boot code properly. I would recommend wiping the first few blocks of the hard drive.

Boot off your Ubuntu CD and use the live Ubuntu system (Try Ubuntu) - don't install Ubuntu.

You can then use a Terminal session as root to run:

# dd if=/dev/zero of=/dev/sda bs=1024 count=10000

That will wipe the first section of the disk - all partition information, boot code, etc.

Of course, you should replace /dev/sda with the actual device node for your hard drive (/dev/sda is probably correct but just make sure before you start with dmesg or ls /dev)

You should then be able to go ahead and install Windows properly.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.