Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am having problems opening a port from one Windows PC on my local network.

On Windows 7 computer ("Computer A") I running Calibre, an ebook management program that has something called an "ebook content server" . In essence, it serves via the web a content catalog.

From Computer A, I can access the content server on localhost. ie. http://127.0.0.1:8787 calls up the content server successfully. With ipconfig I have confirmed that its local IP address is 192.168.1.106 From Computer B (a Vista Machine) I can ping 192.168.1.106 I have tried opening/editing a port in the Windows Firewall several times.

In Windows firewall --> Allowed Programs in Control Panel, I see a listing for Calibre (with both Home/Work and PUblic checked) In details, I see Name: Calibre, Port Number 8787, Protocol TCP

If I use the Advanced Security configuration screen for the firewall, I created an Inbound Rule on Computer A for Calibre (with the settings I indicated).

If I run this command line on Computer A, I see:

netstat -a -n

  TCP    0.0.0.0:554            0.0.0.0:0              LISTENING
  TCP    0.0.0.0:664            0.0.0.0:0              LISTENING
  TCP    0.0.0.0:2869           0.0.0.0:0              LISTENING
  TCP    0.0.0.0:3306           0.0.0.0:0              LISTENING
  TCP    0.0.0.0:5357           0.0.0.0:0              LISTENING
  TCP    0.0.0.0:6570           0.0.0.0:0              LISTENING
  TCP    0.0.0.0:6580           0.0.0.0:0              LISTENING
  TCP    0.0.0.0:8787           0.0.0.0:0              LISTENING
  TCP    0.0.0.0:10243          0.0.0.0:0              LISTENING

 TCP    192.168.1.106:63020    74.125.227.51:80       TIME_WAIT
 TCP    [::]:80                [::]:0                 LISTENING
 TCP    [::]:135               [::]:0                 LISTENING
 TCP    [::]:443               [::]:0                 LISTENING
 TCP    [::]:445               [::]:0                 LISTENING
 TCP    [::]:554               [::]:0                 LISTENING
 TCP    [::]:2869              [::]:0                 LISTENING
 TCP    [::]:5357              [::]:0                 LISTENING
 TCP    [::]:6570              [::]:0                 LISTENING
 TCP    [::]:6580              [::]:0                 LISTENING
 TCP    [::]:10243             [::]:0                 LISTENING
 TCP    [::]:49152             [::]:0                 LISTENING
 TCP    [::]:49153             [::]:0                 LISTENING
 TCP    [::]:49154             [::]:0                 LISTENING
 TCP    [::]:49155             [::]:0                 LISTENING
 TCP    [::]:49170             [::]:0                 LISTENING

And lots of other junk, but this seems relevant, I see port 80 is open (I run xampp apache web server for windows on Machine A) This is the only time I see port 8787 referenced from the netstat commmand.

From Windows Computer B, I can, ping 192.168.1.106 and even view http://drupal.local (on Computer A) and http://192.168.1.106/ (which goes to the Xampp config screen on Computer A).

But I cannot access via Computer B htttp://192.168.1.106:8787 or htttp://computerhosta:8787

So what is going wrong? Is this a problem with the Calibre application or have I incorrectly opened the port? What things could possibly interfere with the opening of this port?

On a sidenote, I have tried using telnet from Computer B to see if port 80 or 8787 is open for 192.168.1.106. I get no reply for either one.

Thanks.

share|improve this question
    
It just might be Calibre. Me & @IvoFlipse were trying to set this up, but it just wouldn't connect –  Sathya Apr 2 '11 at 7:12
    
First off you need to rule out the firewall. Completely disable the firewall (temporarily) on both machines and try it. If it connects OK then try enabling the firewall on one machine and try again. If it fails you know which firewall is getting in the way. It id works enable the second firewall and try again. If disabling both firewalls doesn't let you connect then it must logically be Calibre. –  Majenko Apr 2 '11 at 10:06
    
Ok, now we are getting somewhere. I disabled the firewall Computer A (the one running Calibre) and now Computer B can see the content server fine. More specifically, if I turn off the firewall for Public network locations (but leave on the firewall for home/private networks, I can access Calibre fine. Again, after I reenabled the firewall again, I deleted the original rule and created it again. No success. Firewall says: PUBLIC PROFILE is active; Firewall is on, Inbound connections that do not match a rule are blocked. –  rjnagle Apr 2 '11 at 14:03

1 Answer 1

Ok, I think I solved the problem for now.

I installed calibre on Computer B (Vista 64) and enabled the Calibre Content Server. It prompted me for an "Add an exception for Calibre" and I accepted. From Computer A I could access calibre server, no problem.

That led me to reexamine how I set up things on Computer A (Win 7).

First, on I deleted all references to Calibre in Windows Firewall --> Allowed Programs.

I verified everything was removed on the Advanced Settings screen.

Then I turned on Calibre, the Firewall prompted me to add an exception, which I did.

I checked on public and private network, but later I realized that I could turn off Public network, and it would still work.

One thing I noticed that in allowed programs there were 2 separate entries for Calibre. Either 1 of them was not checked, or the first entry had public checked but not private and vice versa. Ultimately, I made sure there was a check mark for both entries and I made sure that private was checked for both. (The public no longer wasn't necessary).

(I rebooted for unrelated reasons, so that MIGHT be necessary though unlikely).

Problem fixed.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.