Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

On Linux (Gnome desktop) how do you prevent one of the partitions on an external USB drive auto-mounting when it attached to the machine?

I don't just want to prevent the Nautilus window from popping up -- I want that partition not to mount.

Fiddling with /etc/fstab is not acceptable, as this is a removable drive that is attached to different machines.

I seem to remember that you create a hidden file in the root of the file system, but I can't remember what it's called. Something like:

touch /media/usbdisk/.no-mount

How do you actually make this work?

share|improve this question
2  
If I understand you correctly, you want the drive to not be auto-mounted on any linux machine, but without any configuration on the machine itself? – nagul Aug 20 '09 at 16:43

To read that file, the partition would have to be mounted. The auto-mounting is a feature of the operating system (actually hotplug, or some other service monitoring USB) and has to be turned off per-machine.

share|improve this answer

If you're specifically worried about auto-mounting in gnome, and would rather not touch /etc/fstab, try the following command to turn it off for a specific partition:

gnome-mount --write-settings --mount-options noauto --device /dev/sda1

If you no longer want this to happen, erase the settings:

gnome-mount --erase-settings --device /dev/sda1

I also think you can turn off auto-mount altogether through the gconf-editor utililty: *desktop > gnome > volume_manager > automount_media*

I'm not aware of any way to have the auto-mount daemon look for a file on the drive and unmount the drive on finding it, though I can see the utility in having something like this.

share|improve this answer
    
I tried this, but it results in an error: Cannot mount volume - invalid mount option when attempting to mount the volume 'volume label'. Any ideas? – chris Sep 13 '09 at 18:27
    
Can you provide the command you ran, and did you get the error when running the command or when attaching the device? – nagul Sep 13 '09 at 20:12
    
gnome-mount is not in recent distributions like Ubuntu 10.04 Lucid. I've looked but haven't run across a way to do this now. Any tips? The closest I've gotten is stopping all USB auto-opening Disabling auto-open - Ask Ubuntu - Stack Exchange – nealmcb Feb 7 '11 at 5:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.