Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

How can I hide desktop icons in Windows XP x64? The right clicking on the desktop method I used in x86 (32 bit) isn't there.

share|improve this question
add comment

4 Answers 4

up vote 2 down vote accepted

According to this article from Microsoft Technet, you need to set

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\NoDesktop

to the DWORD value 1

share|improve this answer
1  
I did this, worked but I can't even right click desktop to bring up a context menu. –  Andrew G. Johnson Apr 3 '11 at 2:44
    
That’s because as the name of the value implies, Windows does not even create the desktop, so you don’t have a desktop to click! –  Synetech Jul 10 '12 at 1:09
add comment

I found this bit of information:

When you right-click the Desktop and choose Arrange Icons By sub-menu, these three options may be missing:

Show Desktop icons / Lock web items on the Desktop / Run Desktop Cleanup Wizard

This happens if the policy NoActiveDesktopChanges or NoActiveDesktop is enabled via the Group Policy Editor or via the Registry. Follow the steps given below to get back the missing options:

Click Start, Run and type REGEDIT. Navigate to the following key:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Double-click NoActiveDesktopChanges and set it to 0 Double-click NoActiveDesktop and set it to 0 (if it exists)

Close Registry Editor and restart Windows.

share|improve this answer
    
The fact that NoActiveDesktopChanges and NoActiveDesktop are both not there makes me uneasy. –  Andrew G. Johnson Apr 2 '11 at 20:23
    
@Andrew: The key names themselves are suspicious too, desktop icons and active desktop are different. –  Tom Wijsman Apr 2 '11 at 22:59
    
I have been using this one click utility in W7 64bit, works well...howtogeek.com/howto/windows-vista/… –  Moab Apr 2 '11 at 23:22
add comment

Use Fences. When you double click on any blank space on your desktop, all icons disappear; and when you double click again, they come back.

Fences is free for personal use.

share|improve this answer
    
Fences are awsome –  Darius Jul 5 '12 at 2:39
add comment

Here’s an easy way

  1. Go to the tweak ui in Control Panel / Performance and Maintenance and look for desktop next UN-check everything click ok.

  2. Ctrl + left click and get all the icon's you don't want shown next right click on any icon then click properties

    Or: Right click and drag on all the icon's you don't want shown you will be prompted with properties here click it.

  3. See the attributes click hidden then apply then ok there you go!

If you still see them go to Control Panel / Appearance and Themes and folder options click on view look for hidden files and folders click don't show hidden files and folders.

If for some reason you want the icon's back go to Control Panel / Appearance and Themes and folder options click on view look for hidden files and folders click show hidden files and folders then click ok next go to desktop see the icons then follow steps 2 and 3 and that's it!

share|improve this answer
    
But I want to be able to see hidden files and folders... –  Andrew G. Johnson Jul 5 '12 at 3:52
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.