Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a few XenServer VMs all running CentOS 5.5. Some are 32-bit and others are 64-bit.

Every time they boot, the following message appears:

Applying Intel CPU microcode update: [FAILED]

Does anyone know why this is happening and how I can fix it?

share|improve this question

3 Answers 3

up vote 5 down vote accepted

This probably happens because the OS is running inside a VM and therefore can't apply CPU microcode updates. As for how to fix it, I have no idea. Does this message prevent any meaningful work or does it merely disturb you? In the latter case you can safely ignore it.

share|improve this answer
    
Ok, thanks for your help. –  Reado Apr 2 '11 at 21:37
    
This sounds very sensible, a virtual machine should neither need nor be able to apply microcode updates as that (I would have thought) should be handled by the host. –  Mokubai Apr 2 '11 at 21:39

If you want to prevent the Intel CPU microcode from starting at boot, you can disable it as follows: (Run the command as root)

# chkconfig microcode_ctl off

This will prevent the microcode service from trying to apply the update at boot, since it will fail on your VMs every time.

share|improve this answer

On a CentOS 6 installation, microcode_ctl doesn't seem to be invoked via the /etc/init.d (chkconfig) mechanism any more. I achieved the same effect by uninstalling the package:

# rpm --erase microcode_ctl

(I know the original question was centOS 5.5, but a search brought me here...)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.