Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a Dell Inspiron 1525, on which I had previously had a dual-boot Ubuntu 9.10 / Windows Vista set-up (plus some other nonsense that came factor-installed).

There are some similar questions to this, but none have been an answer to my dilemma. I just upgraded from Ubuntu 9.10 to Ubuntu 10.04 (I know, it took me a while). I tried to restart and boot into Windows Vista so I can watch Netflix (which of course isn't compatible with Linux), and Windows Vista is no longer an option in my boot menu.

I tried running sudo update-grub, and this is what I got:

Generating grub.cfg ...
Found linux image: /boot/vmlinuz-2.6.32-30-generic
Found initrd image: /boot/initrd.img-2.6.32-30-generic
Found linux image: /boot/vmlinuz-2.6.31-23-generic
Found initrd image: /boot/initrd.img-2.6.31-23-generic
Found memtest86+ image: /boot/memtest86+.bin
Found Microsoft Windows XP Embedded on /dev/sda1
Found Windows Recovery Environment (loader) on /dev/sda3
Found Microsoft Windows XP Embedded on /dev/sda5

One of those lines should be Windows Vista. Curious, I tried GParted, and it shows one 111.79 GB "unallocated" partion on /dev/sda. Needless to say, this is not actually the case.

Did upgrading to Ubuntu 10.04 break my system? How can I regain access to Windows XP? Thanks for any help....

share|improve this question
Looks to me like grub wrote over the Windows boot manager. Can you select Windows XP from the grub menu at startup? – n0pe Apr 3 '11 at 0:46
up vote 0 down vote accepted

My laptop with Ubuntu 9.04 and 10 did the same thing in one upgrade. They just screwed up and mislabeled Vista as "Recovery environment." Give it a try and it will boot fine!

If you wanna rename it, you'll have to look around in your /boot subfolder for menu.lst from Ubuntu. Then, use a more precise name and be careful not to change anything other than the title.

share|improve this answer
Thank you, that did it! Still not sure why GParted is showing no partitions, though. – eaarthman Apr 3 '11 at 3:33
Glad to help! GParted said "unallocated" for your whole disk, not even for one of its partitions like sda1 or sda2; just gnore it. Partitions sometimes confuse tools randomly, and I try to use a different one if changes must be applied. In case you reinstall Windows or testdrive lots of distributions without a Virtual PC, it's good caution to burn a copy of SuperGrubDisk's ISO (open source). It saved me once when Vista's rescue ate grub's loader for lunch. You can get it here: – Vlueboy Apr 3 '11 at 5:23

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.