Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am setting up Apache server on my Windows 7 machine. My machine is directly connected to the cable modem; so I believe that my machine has an internet IP (not just a local IP). I am able to open my site locally both as 127.0.0.1:81 and myIp:81. But the site doesn't open from another machine. netstat shows this:

TCP    xx.xxx.88.177:81       0.0.0.0:0              LISTENING

I also made an exception in the Windows firewall inbound rules for port 81. But still the web page doesn't open on another machine (on different LAN).


Thanks guys. I guess something was wrong with my firewall. My laptop has been on my corporte domain. 1) i removed it from the corporate domain, 2) disabled firewall {i wasn't able to do this while being on corp domain} -- now the website starts to work on remote machine. 3) re-enabled the firewall and made exceptions/inbound rule. -- still website on remote machine is working!

out of curiosity, should my ip be ping-able? currently, both ping and tracert are timing out.

share|improve this question

migrated from serverfault.com Apr 3 '11 at 8:57

This question came from our site for professional system and network administrators.

    
Is your cable modem filtering incoming traffic perhaps? –  Nils Magne Lunde Apr 3 '11 at 7:50
    
You'd have been better off masking the last two digits of your IP address rather than the first two, that way we can see if you have a routable IP. –  Bryan Apr 3 '11 at 10:55

3 Answers 3

There's a number of websites like auditmypc which have tools to do a security scan on your PC to look for open ports. It will also confirm you IP address for you.

Most modems in their default settings block incoming traffic for your protection. If you haven't done so already you'll need to configure your modem to permit incoming traffic to your chosen port.

share|improve this answer

I would first try to (temporarily) disable your firewall to rule that out as the problem.

If the problem doesn't lie with the firewall, it could be that your ISP is filtering traffic and blocking certain ports. To try to work around this, I would probably try port 80 to see if that works.

I would also make sure you're using the right external address here. If the IP there is the same on your computer, you have a public IP address (internet routable).

share|improve this answer

Ports under 1024 are reserved, and are most likely blocked by your ISP. Wikipedia says that this is used by Torpark, which is an anonymizer, and most likely blocked.

Try something over 1024 (I generally use something above 10000) or use port 80 like suggested. Your IP will most likely change over time, so you'd be better off using a DNS routing service, which updates the DNS settings every time your IP changes.

Good services include:

You cannot rely on your IP address staying the same. These services will turn a domain name (yoursite.com) into the current IP address of your computer. I think you can even camp on someone else's domain through a subdomain for free. I recently did this with a 3G card with DynDNS.

You may need to buy a domain name (only a couple bucks for .info addresses and up to $10 US or so for .com).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.