Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I installed updates via Automatic Updates (I have it set to "Notify but let me choose which to install"). Then I rebooted as prompted. Immediately upon logging in I received the message "You must restart your computer for the updates to take effect." So I did.

Now it continues to give me this message every time I log in, even though no new updates have been installed. Any ideas on how to make it realize that no reboot is needed?

Screenshot

share|improve this question
add comment

3 Answers

up vote 2 down vote accepted

Found the solution. Here's what I did:

  1. Deleted HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate\Auto Update\RebootRequired
  2. Deleted HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\FileRenameOperations
  3. Did a Registry search on HKLM\SYSTEM and deleted every PendingFileRenameOperations value found.
  4. Restarted the Automatic Updates service.

Apparently there had been corruption in a few of the values, indicating a reboot was required even though it wasn't. Completed those steps and voilà! Problem solved!

share|improve this answer
add comment

You can try taking a look at this article.


Try to disable Windows Update, restart ur system then re-enable.

share|improve this answer
    
The nag isn't the problem. The problem is that there aren't any updates to install, thus the nag shouldn't be appearing at all. –  Unsigned Apr 3 '11 at 20:53
    
Check my updated answer. –  Chris Tarazi Apr 3 '11 at 21:01
    
Did that, soon as I re-enabled the box popped up again. –  Unsigned Apr 3 '11 at 21:24
add comment

Sometimes 3rd party security software can cause this, perform a clean boot Once the system restarts and cleanly boots, reverse the settings you changed in msconfig and reboot again, hopefully the message will be gone.

How to configure the system for a Clean Boot

Step 1: Start the System Configuration Utility Click Start, type msconfig in the Start Search box, and then press ENTER.

If you are prompted for an administrator password or for a confirmation, type the password, or provide confirmation.

Step 2: Configure Selective Startup options

In the System Configuration Utility dialog box, click Selective Startup on the General tab.

Click to clear the Load Startup Items check box.

Click the Services tab.

Click to select the Hide All Microsoft Services check box.

Click Disable All, and then click OK.

When you are prompted, click Restart.

.

If you do not get it sorted out contact Microsoft via Free email support for Windows Update.

share|improve this answer
    
Didn't have any effect. –  Unsigned Apr 3 '11 at 21:25
    
Contact MS using the link I posted. –  Moab Apr 3 '11 at 21:33
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.