Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

You are opening the application Skim for the first time. Are you sure you want to open this application?

The application is in a folder named Applications. To see the application in the Finder without opening it, click Show Application.

The warnings are only shown when for example opening a PDF file that opens Skim, but not when opening Skim directly. They are also shown again after rebuilding the Launch Services database. The information about previously opened applications might be stored in /var/folders/*/*/C/com.apple.LaunchServices-*.csstore, because it's modified when I allow opening an application.

defaults write com.apple.LaunchServices LSQuarantine -bool false only disables the dialogs shown when opening quarantined files. xattr -dr com.apple.quarantine SomeApp.app or sudo spctl --master-disable didn't seem to work either.

share|improve this question
    
It seems you need to killall Finder after changing this setting. –  Daniel Serodio May 7 '12 at 14:13
    
@DanielSerodio Or just log out and back in or whatever. It still only disables the dialogs about opening files, not applications. –  Lri May 7 '12 at 14:19
add comment

1 Answer

You can simply open a Terminal window (/Applications/Utilities/Terminal.app) and run this command:

defaults write com.apple.LaunchServices LSQuarantine -bool NO

This will prevent downloaded files from being quarantined. Note that this needs to be run on a per-user basis. If you want it to apply to the whole system, run it with sudo and type your password:

sudo defaults write com.apple.LaunchServices LSQuarantine -bool NO
Password: <your password>
share|improve this answer
    
@Lri I don't believe so, no. I have that enabled and haven't seen one of either message in a while. –  squircle Apr 3 '11 at 22:11
    
I've also set LSQuarantine to false, but I'm only getting these warnings. Try for example downloading iChm, associating chm files with it, and opening a .chm from Finder. –  Lri Apr 3 '11 at 22:41
1  
These two commands had no effect in Mountain Lion. I am still getting Stuffit Expander warnings, for example, every time I open an archive. This did not occur prior to the upgrade to ML –  user152300 Aug 14 '12 at 20:47
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.