Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

A Dell PC has recently started taking from 30-45 minutes to boot up into the login screen.

From there, it functions normally.

The Event Viewer shows nothing unusual, and there are no bad devices in Device Manager.

What else should I be looking at?


It is hanging on a simple black screen, before the BIOS self test. It is a member of a domain. I can't see anything referencing this computer in the event log of the domain controller, but I'm not sure what I should be looking for.

share|improve this question
4  
Which part of the boot process does the system hang on? The black Windows XP screen? The blue screen with no windows? The blue screen with a window in the middle (which message does it hang on)? –  Stephen Jennings Apr 4 '11 at 2:04
    
Is this machine in a workgroup or domain? If domain, any events on the domain controller? –  Chris_K Apr 4 '11 at 2:20
    
Sorry, it is hanging on a simple black screen, before the BIOS self test. It is a member of a domain. I can't see anything referencing this computer in the event log of the domain controller, but I'm not sure what I should be looking for. –  Steve Apr 4 '11 at 2:57

5 Answers 5

It could be that the OS is hanging on trying to allocate or locate a specific resource.

I'm not sure what would be causing this, but reformatting as a last resort is something that has fixed any issue I've ever had but couldn't find a way to solve.

You could also try defragging the machine, as well as running the 'error-checking' tool.

EDIT

Based on the update that the PC is hanging before the BIOS screen, what I have listed wouldn't really help. Although they are still good tips for helping speed up a computer that is running slow after the OS has been loaded.

share|improve this answer

Since it hangs before the OS is loaded, I would expect it to be an issue with the BIOS waiting for some device. In the BIOS, try disabling all ATA and SATA controllers that are not in use. Make sure your boot order is set to first boot from the primary hard drive and not any USB, CD/DVD floppy drives, or secondary hard drives. Sometimes the BIOS will have an error log with useful information.

share|improve this answer

I'd look at the hard drive. Perhaps it suffers from a slow spinup or something like "stiction" where it needs a bit more oomph to get spinning and up to speed.

You might pull the current drive out and toss in another then power it up just to see if you get past that black screen any faster. If so, then time to clone the existing drive and replace it.

share|improve this answer

Use Process monitor to enable boot time logging, then reboot, then look at the logs.

http://www.msigeek.com/6231/how-to-enable-system-boot-time-logging-using-process-monitor-tool

share|improve this answer
up vote 3 down vote accepted

Surprisingly, when we replaced the desktop PC with another, the issue remained.

Replacing the monitor resolved the problem. It wasn't slowing down the PC, it was just not powering on properly for some time.

I appreciate all your answers, thanks.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.