Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

After an errant update to OSX 10.6.7 my MacBook Pro stalls at ethernet configuration with a

"Ethernet [AppleBCM5701Ethernet]: Link up on en0, 1 Gigabit, Full-duplex, Symmetric flow-control, Debug [796d,0f01,0de1,0300,cde1,3c00]

DSMOS has arrived"

That's where it ends. There is a ethernet cable attached when I get this message. When booting with it unplugged I get a stall after the bluetooth initialization which is traditionally a line before.

The system was working perfectly before the update, as I did a restore from a time machine backup.

The problem is that I don't have a system disc to boot from. My reseller gave me one for the wrong model and they are, "slightly less than available.."

Not quite sure where to go from here. I managed to boot from a USB sparsebundle image from my Brother's MBP, but don't know how to go about fixing the issue at hand as I can't install a 10.6.6 update on a 10.6.7 hard drive from a USB drive.

And now, obviously, I can't boot from the hard drive or know how to gain root access to attempt to fix things.

Am I screwed or do I need to slouch into a local reseller and have them fix things?

Thanks in advance.

PS: System specs: MBP 13" 2.66 C2D, July 2010, 8Gb, 1Tb.

share|improve this question
    
FYI, "DSMOS has arrived" means that the boot process is over. I had a friend with a problem similar to this a few years ago and an Archive & Install fixed the problem. – squircle Apr 4 '11 at 3:44
    
@squricle Thanks for the info, everything helps. – Steve Apr 5 '11 at 3:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.