Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a D-Link Xtreme N Gigabit Router (, which has worked fine for the past year since I bought it. I recently moved and changed internet providers. Now, once every day or two, the router stops responding - no internet traffic goes through, and I can't even bring up the admin interface for the router. I have to cycle the power on it, then it works fine again. LAN traffic seems unaffected. I updated the BIOS, what else could the problem be?

share|improve this question
Could it be overheating? – Tester101 Aug 20 '09 at 17:49
Not likely, the lights keep flashing and a quick power cycle brings it back up for another 12-48 hours. – sangretu Aug 20 '09 at 17:52
Cable, fiber, or phone coming in from isp? – Tester101 Aug 20 '09 at 18:01
Input is ethernet from the cable modem. In the past, this router has been pretty forgiving about losing its external link, and picks it back up pretty reliably when it returns. Also, when I cycle the power on the router, I don't do anything else - the cable modem and its connection remain as-is. – sangretu Aug 20 '09 at 18:05

Something you might want to consider:

In this area, we tend to get frequent power glitches and brownouts in the summer months. If the power goes out-- even for the tiniest fraction of a second-- the router lights will be on but it becomes non-responsive. But, like you, a simple power cycle solves the problem.

I'm not sure why the electricity going out for a second acts any differently than disconnecting the power cord for a second. But the solution was to plug the router into the UPS.

P.S. My router is a LinkSys WRK54G wireless router.

share|improve this answer
The router is connected to a UPS device. I will take a look at the connection, however, and run some tests to make sure it's being protected adequately. Good point, thanks. – sangretu Aug 20 '09 at 18:06
Have a licensed electrician test the receptacle, you may have bigger problems then you router not working. – Tester101 Aug 20 '09 at 18:14
@tester101 - Me? I live in Central Florida. Everyday: "Hazy, hot and humid, high in the upper 90's, chance of thunderstorms in the afternoon" all summer. The local utility is nick-named "Florida Flash and Flicker" for a reason. It's pretty much a state-wide problem. – Robert Cartaino Aug 20 '09 at 18:37
While the electrician is there have him install a surge suppressor on the main circuit panel as well. (Keep in mind that even with such a device, it is recomended that surge supressor power strips be used to protect devices). – Tester101 Aug 20 '09 at 18:46
Seconded. I face this problem with my D-Link router. Despite being behind a voltage stabilizer, once in a while when there is some sort of a power fluctuation that gets through to the router, the router stops responding while still glowing its several indicator lights. The solution is a quick power-cycle. – ayaz Feb 20 '10 at 18:42

Have you made any changes in your usage patterns? Many routers have issues with services like bittorrent. I've seen this happen with a few models of d-link and linksys and it behaves exactly as you describe.

Basically anything that creates a big amount of connections like bittorrent and emule can cause your router to behave like that.

share|improve this answer

Try disabling DNS Relay at Setup > Router Settings > Router Settings and uncheck Enable DNS Relay. I've done a fair amount of reading on this fix and there's no noticeable performance hit. I have had the same problem with my DIR-655 and a DGL-4300 before that. The symptoms I experienced are that the internet would slow to a crawl then stop responding, LAN continues working, but the admin screen on the router does not load. Disabling DNS Relay resolved this for me.

share|improve this answer

If you have your router set to .11n and near your router there is an AP set to .11/BG there might be some problems.

share|improve this answer
What do you mean by "AP"? Wireless access point? I'm not trying to connect to the router wirelessly - all of the systems on the network are currently wired. – sangretu Aug 20 '09 at 18:08

I have a D-Link DIR-615, and it works great. I bought one for a friend for their birthday, and its the same model but a different HW Revision. It would suddenly quit allowing internet traffic for all but one of the connected computers, but they were still all connected. The one that worked was a MacBook hooked up by ethernet. It eventually quit doing this (after 3 upgrades and downgrades of firmware), and then my own started doing it. What was happening to mine, all of the IP addresses were being reserved for a device that had no mac address and never expired. So it would work for a day, then all of the addresses would be taken up and it would quit working. The macbook on the other router was fine because it was connected by ethernet and never had to renew its address. To fix it, I reserved the IP address for all of my home computers and have had no problems since.

share|improve this answer
Hmm. I've been reserving IPs for my systems. Maybe next time it happens I'll try accessing the administrative console from different systems and see if any of them can get through. Not having a view into what's happening is making it difficult to troubleshoot. – sangretu Aug 20 '09 at 18:28
You said you have LAN traffic correct? I couldnt always get a fix by unplugging and plugging back in, i had to reboot from the router itself to get the DHCP reset. – PiroThePyro Aug 20 '09 at 18:43
I think I still have LAN traffic (need to verify), but I can't bring up the administrative console on the router. – sangretu Aug 20 '09 at 19:42

Can you PING the LAN interface?

Can you Telnet into the LAN Interface?

Is your ISP DSL perhaps? Your ISP may be resetting your IP address & the router is hung trying to acquire a new IP address. Power cycling the router causes it to work.

You might try putting another (cheap) router in front of it (between the ISP & the DLink) to see it that router handles the DHCP issue. e.g.:


Make suer that your LAN and Router 1's LAN are different subnets.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.