Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I think I found a bug for synergy. I have tried it in 1.3.6 and 1.4.2 beta, I also got a user (frankivo) on the synergy IRC channel to verify it.

Steps to reproduce (on a client):
1. Open a text editor
2. Press one of the shift keys and keep it depressed
3. Type: ACTIVE
4. Press the other shift key and release it (while still keeping the other shift depressed)
5. Type: SHIFT

Result: ACTIVEshift
Expected result: ACTIVESHIFT

So, the shift status gets set to deactivated when any shift key is deactivated without checking for any other keys.

Hope someone can verify this and file a proper bug/issue since new users aren't allowed to do so.

share|improve this question
up vote 1 down vote accepted

This is part of a long-term bug in Synergy 1. It is top priority for dealing with in the new Synergy 2:

Version 2 requirement

Modifier keys (and in fact all keys) must not get "stuck on", as this was the most >significant bug in version 1. The problem was intermittent, but perhaps unit/integration >tests can be used to test this.

The original bug has been known about and tried to be tackled many times for a number of years now.

If you think it should be reported as a separate bug you should do so with the Synergy Issue Tracker. Note: you need to register first.

share|improve this answer
    
Thanks for the answer.Now I know it is being dealt with (albeit slowly). That's all, I'll just work around it until then! – imightbewrong Apr 4 '11 at 9:31

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .