Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a distribution called Easy Peasy on my netbook, it's Ubuntu-based.

Today when I started it up it told me 'grub corrupt'. On subsequent start-ups it displays 'unknown filesystem.' I'm given a prompt labelled 'grub-rescue>' but I can't get any commands to work (even just 'help').

I've tried booting off a Live CD of Easy Peasy. That works fine, but I can't get to my files. I've tried using a program called photorec and it can recover files from the drive but it dumps out gigs upon gigs of unlabelled files, many of which are things like system files or web browser cache -- I only have a few dozen text files I actually need, so this is pretty unworkable.

I'm trying to reinstall grub, which I understand to be part of the booting process, but I've had no luck; any set of instructions I've followed has inevitably run into some error or a step I don't understand.

How can I get at my files in an easy to recognise way (such that I can navigate the original directories and get what I want)?


How can I easily reinstall grub such that I can just use the system like before without having to reinstall everything and lose my files?

I think my drive is sda or sda0. In grub's it's called hd0.

I have almost no linux knowledge. Simple steps would be much appreciated.

share|improve this question
Also, in a lot of the guides I've followed a common problem seems to be things like the drive sda0 can't be found or can't be written to or isn't mounted... playing around with commands like mount didn't help either. – Fergus Apr 4 '11 at 11:44

Photorec is pretty bad about that. Unless something very bad happened to your disk (in which case testdisk - by the same people who wrote photorecmay help), any linux system should be able to mount and copy out your information. If not, you need to look at recovery...

As with any recovery scenario, i'd strongly suggest imaging your disk before trying anything. Then if you cannot recover the contents of the disk, try running testdisk to try to recover the whole file system.

Should that work you're likely to be able to recover your disk without any further steps, or at most recovering grub. To recover grub this process should help - its for ubuntu but easy peasy is a varient, and should work.

share|improve this answer
I can't figure out how to mount it. I think the problem is that I don't know what filesystem it is. I've tried to use all the ones I can think of with the mount command -- vfat, ext2, ext3, a few others. Any tips? – Fergus Apr 4 '11 at 13:25
cd /dev/ then ls and look for entries starting with hd or sd (eg sda sda1 or hda hda1). then try the mount command for those. – Journeyman Geek Apr 4 '11 at 14:26
I've got sda sda1 sda2 and sda5. If I try to just do mount sda (etc) it tells me 'cannot find sda in etc/fstab or etc/mtab'. If I try mount /dev/sda /mnt/sda (after making that folder) it tells me '/dev/sda already mounted or /mnt/sda busy.' If I try 'mount /dev/sda1 (or 2) /mnt/sda' it tells me 'you must specify the filesystem type.' If I add on '-t vfat' (or other types) it tells me 'wrong fs type, bad option, bad superblock on /dev/sda1, missing codepage or helper program, or other error.' dmesg |tail tells me 'Can't find an (whatever) filesystem on dev sda1.' – Fergus Apr 4 '11 at 14:35
run testdisk. sounds like the file system is damaged. – Journeyman Geek Apr 4 '11 at 14:37

If you can't get the main partition mounted, you won't have much luck reinstalling grub.

So let's first look at the disk:

fdisk -l /dev/sda

That should tell us if the disk is being recognized, and if the partition table is ok.

share|improve this answer
'Cannot open /dev/sda' It also says the filesystem is unrecognised in GParted. – Fergus Apr 4 '11 at 14:14

Assuming the drive is not corrupt or broken, the simplest thing would be to simply reinstall Easy Peasy. It only takes half an hour, and if you do not choose to format the drive it won't lose any of your data.

share|improve this answer
Well, I guess I'll just go for this. – Fergus Apr 4 '11 at 14:15
No, it doesn't seem to recognise the filesystem or something. The installer made it clear that I would have to wipe it. – Fergus Apr 4 '11 at 14:26
Your drive is corrupted, or possibly broken. I hope you have good backups. – CarlF Apr 4 '11 at 17:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .