Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Recently I encountered an odd problem with Visual Studio. Both in the 2008 and 2010 editions where certain images, colors and gradients in the GUI fail to load.

After various reinstalls of the program and related components, and some long phone calls with Microsoft technical support, I opened WordPad one day, and realized that this problem is not tied to visual studio at all.

WordPad and MSPaint have the same problem. I don't know what is responsible for the GUI in the three programs, but it appears that images and gradients are missing from the interface, causing the same sort of effects in all three.

I have screenshots of all three programs: (Visual Studio 2010) (WordPad) (MSPaint)

If anyone has any ideas, I'm willing to try them and post back - I know that this problem could be solved by simply reinstalling Windows, but I would like to figure out the issue in case of future problems.

share|improve this question
Could you make your links actual links please – ChrisF Apr 4 '11 at 13:10
I can make two of them actual links - I need 10 Rep to have more than two links. Sorry - Just wanted to be consistent with them. – WilHall Apr 4 '11 at 13:11
It's better that they're links. – ChrisF Apr 4 '11 at 13:14
@WilHall: What are those tabs at the top of the first screenshot? Do you have some kind of add-on for Windows? If so then have you tried disabling it and restarting? Also, what graphics card/drivers do you have? Finally, have you tried the Windows repair facility? – James Apr 4 '11 at 13:19
@James: Those tabs are ObjectDock. It's not exactly an add on as much as it is a separate program. I've had it for awhile and the problem was nonexistent in the past. – WilHall Apr 4 '11 at 13:21

It's difficult to tell for sure but I suspect that you've somehow set the colour depth of your graphics card down to 16 bit or even lower.

Select "Screen Resolution" from the desktop context menu then "Advanced settings".

This gives the properties dialog with the tabs "Adaptor | Monitor | Troubleshoot etc."

Select "Monitor" and at the bottom there's a drop down called "Colors".

Make sure that's set to "True Color (32 bit)".

share|improve this answer
That is what I tried originally too - but my depth is set to 32bit. I checked again just now to be sure. Also - It is only with certain applications. The three I listed are the ones I have noticed to be effected. This makes me think that some component they used isn't installed or working correctly. If it is about color depth, is there any way that something could have got set on a per-application-basis? – WilHall Apr 4 '11 at 13:15
up vote 0 down vote accepted


Reset the windows theme to a default setting. Somehow, my current theme was corrupted.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .