Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just recently installed Windows 7 SP 1 on my computer. However it failed, and I rolled back the installation, only to now have an error with my ethernet port, saying that I cannot connect, for the stated reason.

How can I fix this? Without having to format my PC?

I have tried

  • Resetting Winsock
  • Flushing my DNS via ipconfig.
  • Disabled/ Enabled my network adapter.
share|improve this question

migrated from serverfault.com Apr 4 '11 at 18:49

This question came from our site for professional system and network administrators.

    
You need to tell us a little more about your network -- are you at home or at work? What do you know about your network connection outside your laptop? The Ethernet port is probably correct, but it cannot find a path to the wider world -- perhaps because of a local network configuration (like a proxy server you need to know about), or perhaps because of the Windows 7 security has been set up. –  Johnnie Odom Apr 3 '11 at 21:53
    
This is a home network. I am running Windows 7 on my desktop computer. I am posting this comment from my laptop. –  JCubed Apr 4 '11 at 6:47
    
This is a home network. I am running Windows 7 on my desktop computer. I am posting this comment from my laptop. I have never had to do this before, as it was all automatically handled. My router is a DGl-4300, and I just have a modem that comcast gave me. I tried rolling back my update, but I get a strange hex error. I know its an OS error, because my ethernet port works when I boot into ubuntu. Is this enough information? **edit –  JCubed Apr 4 '11 at 7:51
    
Can you reinstall the ethernet drivers? –  tjameson Apr 4 '11 at 16:49
    
Can you please try resetting your IE settings on Tools - Internet option - Advanced - Reset settings? –  user107596 Dec 1 '11 at 4:29

1 Answer 1

I tried doing so. I uninstalled my ethernet drivers, I rebooted my machine, and still, I encountered the error. I'm just gonna take my chances with guessing that SP 1 borked my machine, and so I am reinstalling windows.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.