Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Using the USB capabilities of the VirtualBox, I've tried in tried different computers and just keep receiving the message that the USB device is busy with a previous request. I'm trying to access the USB stuff since the first version (now using 3.0.4), but I was never successful.

Is there any special configuration or tweak to make?

share|improve this question
1  
Did you install Guest Additions and are you using the VirtualBox standard or OSE? As far as I know the open source edition doesn't support USB. –  Gren Aug 20 '09 at 18:48
    
I've installed the Guest Additions and I'm using the OSE version. I've tried with XP and Vista. Everything looks fine, the USB driver is installed on the host on the first time an USB resquest is made but nothing happens on the guest, and when I try to access the device again I receive the "device is busy" message. –  Eder Gusatto Aug 20 '09 at 18:56
    
I have XP and Vista Guests over a Vista Host and Windows 7 Guest over a XP Host. –  Eder Gusatto Aug 20 '09 at 19:01
1  
I ran into the same problem (VBox OSE), and found that rebooting helped. After that, I really didn't have any problems. –  J. Polfer Aug 20 '09 at 19:10
    
Well, in fact rebooting both guest and host helped indeed. It doesn't work flawlessly though. But I really should have tried the default windows action for panic situations, aka reboot. I guess I deserve a forcible relocation to an agrarian society. dilbert.com/strips/comic/2008-12-24 –  Eder Gusatto Aug 21 '09 at 19:26
show 1 more comment

4 Answers

I've encountered the same problem after upgrading from VirtualBox 2.2.2 to 3.1.6, and regrettably rebooting had no effect. However, after searching for a long time, I found the solution on the VirtualBox forum:

With VirtualBox shut down, remove the USB device from your host. Then restart VirtualBox, start the virtual machine, and then reattach the USB device. Now, VirtualBox recognizes the devices.

Note: I did the test with Windows Vista and Windows 7.

share|improve this answer
add comment

You will want to set a USB filter and also enable USB for the virtual machine. Under the settings of your virtual machine, go to the USB tab. You will want to make sure the USB Controller is enabled first and foremost. Then (while your usb device is plugged in) add a filter for it, the process is fairly straightforward.

share|improve this answer
    
This does not solve the problem. Source: I have the OP's problem as well. –  KyleM Apr 2 at 19:54
add comment

Normally you just put in whatever USB device you want to pass through (I normally use USB keys) in the settings, fire up the VM, and it works.

Did you install the host USB controller when you installed VirtualBox? What OS are you using?

share|improve this answer
add comment

With Mac OS X Lion and VirtualBox 4.1.4 I had to reboot the MAC (guest). Then adding the filter and plugging the device when the VM is running correctly captures the USB device.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.