Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I got echo indigo djx expresscard as an audio card.

I use Ubuntu 10.10.

if I insert the card and reboot. it works.

if I just insert the card, it doesn't make sound. the blue led is on. I tried killing pulse audio but it restarts automatically and still no sound.

share|improve this question
Sounds like a stupid simple thing, but did you reroute the output using Sound Preferences. It's probably not automatic... – tjameson Apr 5 '11 at 7:30
yeah i did. if i boot without card it doesn't show up in sound pref. if i boot with the card then i take it out and put back in, then i see the card but it doesn't make sound. i would assume i should renew or reload expresscard but i'm not sure how to do it – kirill_igum Apr 7 '11 at 19:28

Do lspci to see if your device is even recognized by Ubuntu. If it is, try this:

Restart ALSA:

killall pulseaudio
sudo alsa force-reload

then you can try this to show what devices you have: aplay -l
share|improve this answer
i rebooted without the device and the device doesn't appear in lspci. i tried 'sudo modprobe snd-indigodjx' and nothing happened. even if i plug in the device, it doesn't show in dmesg. but everything works if i just restart – kirill_igum Apr 19 '11 at 2:29
up vote 0 down vote accepted

add a line




and reboot the computer. plug and play will for for the expresscard. source:

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .