Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm doing development on OS X while my actual code lives on a remote CentOS box that I have mounted as a local share (smbfs). Some of my files are not marked as writable and need to be toggled when I go to edit them. In Terminal if I go to any location under my smbfs mount and do a chmod to anything it never takes, I have to SSH to the server to toggle perms. Any ideas as to why this won't take?

Really weird: Using PhpStorm to edit files from this share fails to toggle the permissions to writable on read-only files however Eclipse can toggle them without an issue.

share|improve this question
up vote 0 down vote accepted

CIFS (SMB) is primarily a Windows protocol and does not support POSIX access permissions unless "Unix extensions" are enabled. Apparently, the smbfs filesystem does not support this.

  • On Linux, a newer cifs filesystem module exists as part of smbclient. It support POSIX file permissions, including ACLs. (Probably not on OS X, though.)

  • Alternatively, you can use SFTP (sshfs through MacFUSE) to access the files.

    SFTP is the SSH file transfer protocol. You already have working SSH, so there's nothing you need to set up server-side.

share|improve this answer
SFTP with MacFUSE + MacFusion allowed the chmod. Thanks for the info. – nortron Apr 6 '11 at 0:09

If it's not what grawity said, it could be a numeric User ID mismatch between the client and the server. What's the numeric user ID of the account you're logging into Mac OS X as (do id -u)? What's the numeric user ID of the account on the Cent OS box that you're using when you connect via SMB?

share|improve this answer
The IDs did not match. Updating the CentOS box's user ID to match didn't have any effect though. – nortron Apr 6 '11 at 0:10

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.