Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am having this annoying problem with Google Chrome, although I used to love Chrome I will switch to Firefox if the problem persists.

Sometimes while loading a page Chrome fails and displays ERR_TIMED_OUT error.

enter image description here

This does not occur every time, in average out of 10 page loads 1 fails. When I hit refresh a couple of times, it will load eventually.

I am using Firefox for a couple of hours now and it seems to work fine.

So far I tried these: clearing cache, switching user profiles, disabling DNS prefetching, disabling detection of connection settings automatically in IE (yes, I don't know why this is here, but I remember having the same problem a few years ago and this worked). I run out of ideas.

How can I prevent this error from happening? Or at least how can I trace the source of this error?

share|improve this question
Maybe you have bad latency? Try doing a speed test. This is more likely a network problem than a problem with Chrome. – tjameson Apr 5 '11 at 7:51
You may also try using other DNS server (eg; openDNS) if your internet connection has no issues with speed. – Kushal Apr 5 '11 at 7:55
@tjameson and @Kush: Firefox and IE works fine. – nimcap Apr 5 '11 at 8:06
Got the same issue. Only happens in Chrome with localhost. Very irritating! – ysrb Oct 24 '13 at 14:00
Doesn't Chrome load links on a page automatically in case you need them ? That may be whe its timing out. I gave up on CHrome a while ago because of speed issues. – Rohit Gupta Nov 20 '15 at 0:55

I've got the same problem when I choose another ISP. I thought I would have only to put my new ID and password, but it wasn't the case.

I have an ADSL modem with a dry loop. To resolve the problem ERR_TIMED_OUT, I had to ajusted the MTU ans MRU values. I put 1458 rather than 1492, which is the default value. It works for me. Good luck.

share|improve this answer
The OP's problem is only with Chrome. Other browers work fine. Your answer is for a different problem. – DavidPostill Jul 11 '15 at 23:17

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.