Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to install sap business one on my computer. But I can't seem to connect to the database server which is ms sql.

I get the notice: unable to connect to the database server name, and that database is started. Here's what I did:

  • Enabled TCP/IP protocol
  • Restarted the service

I already tried every single possibility that I could think of:

  • COMPUTERNAME/SQLEXPRESS
  • localhost

The username and password that I'm using is: sa and b1admin. Which I think is the default as I have seen from the Sql server management studio:

Note: The image isn't updated. I already have the SBO-COMMON database when I'm trying to connect to it. But I just can't connect.

share|improve this question
up vote 1 down vote accepted

It's not normal for the database to be located on your own computer. Normally this database is on a central server shared by all the employees, and managed by your IT department. You need to ask IT what the name of the server is.

share|improve this answer
    
I get it now, it seems that I haven't enabled the other tcp/ip protocol – user75238 Apr 6 '11 at 14:13

I know this is an old question, but for anyone else trying to connect to a local instance of SQL Server Express the default server name is:

COMPUTER\SQLEXPRESS

so a back slash not a forward slash. You can use localhost if it is on the local pc or the name of the remote computer as appropriate.

share|improve this answer
    
The reason for this is that the backslash separates the server name from the instance name. If you are connecting to the default instance, you can often omit the \instancename part, leaving only the server name. – Michael Kjörling May 10 at 15:31

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .