Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Trying to use a dual-monitor desktop system with Windows XP.... 1 graphics card... with digital/analog outputs.

Picking: Desktop -> Properties -> Settings -> Identify

It shows "2" as my left monitor... and "1" as my right. How do I switch them around?

Here's what I've tried so far:


Switch the cables (I can't.  I need the digital cable on the better monitor.)
Switch the monitors (I can't.  One has a few dead pixels.)
Drag the 1+2 graphics around (That doesn't change the IDENTIFY numbers.)
Pick "use as primary" or "extend"  (That doesn't change the IDENTIFY numbers.)

Anything else I can try?
What exactly controls/switches the "IDENTIFY numbers" around?

I know it can be done. For weeks I ran this exact set-up... with the CORRECT numbers appearing on the monitors.... then just recently... after a few reboots... they now appear "switched around".

share|improve this question

4 Answers 4

The identify numbers don't matter. They are just for your benefit in, yaknow, identifying the monitors, and could just as easily be color coded or something. You can drag the monitors around so that they work correctly but it's irrelevant what the numbers actually are - 2 can be on the left, 7 can be the primary, whatever. (The display in front of me right now is, left to right, 2 - 1 - 3.)

If you're just OCD and you HAVE to have 1 on the left, you're out of luck; this is determined by how the monitors are physically cabled to the card so you'd have to switch the cables. (I'm not sure why yours switched spontaneously, I'm guessing a driver update.)

share|improve this answer
1  
It could also have been some kind of hardware change (adding/moving/removing a PCI card) that reordered the way the PC addresses the hardware. –  Chris Nava Apr 6 '11 at 20:01
    
@Chris - I've never seen that unless there was another video card involved, but it's an intriguing possibility. I may have to play with that sometime... –  Shinrai Apr 6 '11 at 20:04
    
I have only seen it with another video card also. I was trying to be vague since I can conceive of a PCI port change rearranging the order with which the OS internally initializes the cards. –  Chris Nava Apr 7 '11 at 4:19

The identification numbers generally list 1 as the primary and 2 as the secondary but you can switch this around in XP...

Under the settings page select the monitor icon you want as your primary and check Use this device as the primary monitor. This will make that monitor the default one for for applications to open on.

If you want the numbers to change you need to swap the cables on the Video card.

share|improve this answer

This is a setup issue with Windows. There are very valid reasons for making sure one monitor is the primary and the other is secondary. For example, you may have custom software that expect the secondary monitor in a particular location.

This works for me with two DVI outputs. I have not tried it with an analog and DVI combo. Fix:

  • Turn off the computer
  • Unplug the monitor you want as 2 (at the monitor is OK)
  • Turn on the computer
  • Configure monitor 1's resolution
  • Turn off the computer
  • Plug in monitor 2
  • Turn on the computer
  • Verify that the monitors are correctly identified as 1 and 2
  • Configure monitor 2's resolution
share|improve this answer
    
You can just tell Windows that you want #2 to be the primary rather than doing all this... –  Shinrai Apr 7 '11 at 14:09
    
@Shinrai: Not really. Some software uses the enumerations of the monitors instead of Windows' definition of "primary". For example, in Qt QDesktopWidget::screenGeometry(0).{width|height}() always returns data for the monitor Windows lists as monitor 1 and not the one that is marked primary. –  dwj Apr 7 '11 at 15:52
    
Well, yeah, there's always coding shortcuts to worry about... –  Shinrai Apr 7 '11 at 16:06

Right-click on Desktop and select Graphics Options | Output To | Extended Desktop | Digital Display + Monitor.

I was trying to fix my wallpaper and this fixed the Primary Monitor problem as well.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.