Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Hey. I've been using PuTTY to SSH into my Mac a bunch. When I did that I got the screen: login as: username, Using keyboard-interactive authentication, Password: Which worked fine. But after I tried using a mac Veency app (Screens) and making NO MAJOR CHANGES, it has the prompt Using username "username"., username@xxx.xxx.xxx.xxx's password: and won't accept my (correct) password.

What could have caused this? Does it have to do with the prompt change? How do I change it all back?

Thanks.

share|improve this question
add comment

migrated from stackoverflow.com Apr 6 '11 at 20:59

This question came from our site for professional and enthusiast programmers.

1 Answer

up vote 0 down vote accepted

There are two ways Putty can have the username embedded for logging in.

  1. In the connect string - such as "username@ww.xx.yy.zz" instead of just "ww.xx.yy.zz"

enter image description here

  1. In the configuration - there is a setting for who to connect as.

enter image description here

Note the two radio buttons - if that is set to use the system username instead of to prompt it will result in your problem happening.

So there's three possibilities - you have username@... in the connect string, a username in the configuration box, or it is set to not prompt but use your local username.

share|improve this answer
    
Nevermind, My ip address was e.g. xxx.xxx.xxx.xx2 instead of xxx.xxx.xxx.xx1. the interesting thing is it WAS ....xx1, but changed to ....xx2. Thanks anyway. –  JShoe Apr 6 '11 at 21:04
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.