Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to connect to a networked named "magicmamaliga" but iwconfig isn't letting me.

When running:

iwconfig wlan0 essid "magicmamaliga" key "s:PASSWORDXXXXX"

and get:

Error for wireless request "Set Encode" (8B2A) :
Set failed on device wlan0 ; invalid argument

I have a feeling it might be how I entered the password/key. The security on the network is WPA2

EDIT: I believe this might be a driver issue. I'm on an eeepc 1002HA.

share|improve this question
up vote 1 down vote accepted

This conversation seems to do the trick.

iwconfig ra0 mode managed

iwpriv ra0 set AuthMode=WPA2PSK

iwpriv ra0 set EncrypType=AES

iwconfig ra0 essid "my ESSID"

iwpriv ra0 set WPAPSK="my psk ascii passphrase"

iwconfig ra0 essid "my ESSID"

//using WPA2, PSK, AES.

Tell me if that works for you too or if we need to look into more options.

share|improve this answer
    
For some reason whenever I use iwpriv, it says wlan0 no private ioctls – n0pe Apr 7 '11 at 13:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .