Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a VM running Fedora 17 on VMWare over windows 7. I want to SSH to my university server from fedora but when I try something like:

ssh myuser@server.com

I don't get request for my password. If I try to SSH using PuTTY in windows, everything is OK.

Then I pinged the server and got the following message:

From 192.168.0.106: icmp_seq=2 Redirect Network(New nexthop: 192.168.0.1)

It repeated over and over. Anyone knows how to solve this issue?

PS: I tried NAT and Bridged network connection on the VM, but I'm not sure what this means completely, so I may have messed up somewhere around here.

share|improve this question

2 Answers 2

  1. Make sure you can connect to the internet using your VM.
  2. I usually set them to Bridged...means they get their own IP address from the dhcp server rather than piggybacking off your win7 machine's ip.
  3. You might want to use the ip address of the server as opposed to it's DNS name.

Windows 7 has it's nice firewall which will kill ICMP connections like pings so that could be what you are seeing there. It depends on what ip address does your Win7 machine have and also that could be your host and client ip addresses if you set the vm to host networking only. Sadly there are many things to check there.

share|improve this answer
    
I have internet connection, both on windows and on VM. I tried to ping the IP rather than the DNS and got no response. I've tested on more wireless networks so I believe it's something related to windows or VMWare. Anyway, I installed Fedora on my hard drive. I needed this fast, couldn't wait...thx anyway –  Thiago Moraes Apr 7 '11 at 12:20

Just so you know:

NAT -> Network address translation, it's the same thing your home network does to take the one ip your ISP provides and gives you many private ip addresses. bridged -> gives the host direct access to the host network, almost like they are on a switch.

  1. Set the guest OS to bridged and issue a ifdown eth0 then a ifup eth0 (assuming one nic and root priv.)
  2. then issue an ifconfig and be sure you have the same segment as the host (ie. 192.168.0.xxx) and be sure you have access to the internet.
  3. If all the conditions are met and you still cannot access the SSH server, you are missing key information
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.