Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Full disclosure: I'm predominantly a Chrome user on Windows, but I finally let Firefox download and install the latest version, 4.0. Considering this version has been in development forever, I frankly expected better.

It appears that they've "improved" text rendering by applying font smoothing or anti-aliasing across the entire user interface—not just the text displayed on the pages themselves, but also the text in menus, toolbars, and dialog boxes. Even the context menus use a re-hinted version of Segoe UI.

I think it's blurry and very difficult to read. How do I turn it off? I can't find anything in the Options dialog that looks useful. Perhaps it's something in about:config, but I don't know enough about Firefox to know where to start looking. I can't imagine they would make such a dramatic change without providing the facility to revert to the classic rendering mode if the user so desired. Open source software is notorious for gratuitous customizability; here's a case where I would actually appreciate it.

Additionally, I've discovered that I frequently out-run its ability to process input. In every text entry field that I've come across, I've out-typed Firefox's ability to display each character. More than once, I've even managed to crash the browser trying to type, with only one tab loaded. I suspect this is related to the font rendering changes, as anti-aliasing requires more computing "umph". I'm hoping that if I find the button to turn that off, it'll fix the severe typing lag. But if anyone just so happens to have any other suggestions on how I might fix that, I'm all ears.

The machine in question is a Dual Xeon with 5 GB of RAM running Windows Server 2008 R2, 64-bit.

share|improve this question

1 Answer 1

up vote 5 down vote accepted
  1. Navigate to about:config
  2. Find the item labeled gfx.direct2d.disabled, and change its value to True.

This turns off hardware acceleration and should make your fonts more readable.

share|improve this answer
    
Excellent, that helped a lot. (Although it's still significantly slower than Chrome, and I still see some typing lag.) Also, is this the same thing as the "Use hardware acceleration when available" checkbox under the "Advanced" tab in the Options dialog? –  Cody Gray Apr 10 '11 at 5:09
    
I believe so. There is a rather interesting thread about this over at Mozillazine: forums.mozillazine.org/viewtopic.php?f=23&t=2060933. –  CGA Apr 10 '11 at 18:01
    
Hmm yeah, it looks like it is. And I read as much of that discussion as I could stand. It's just a bunch of uninformed people ranting and theorizing. There's no official word from any of the devs (but a lot of reasons why I prefer SE to traditional forums). If this is what fonts are going to look like now on Windows, I'm going to have to give it up completely for the Mac. I can't use WPF applications like Expression Blend for the same reason—the fonts look like crap. It's just not that hard to get font rendering right; not sure why MS has so much trouble. Nor why Mozilla has adopted it... –  Cody Gray Apr 11 '11 at 8:02
    
Thank you very much. It now works perfectly with MacType and now I can see pretty customized font rendered text instead of ugly ClearType. Despite the question is about Firefox 4, it works for Firefox 16 as well. So thanks again! –  Lyubomyr Shaydariv Oct 27 '12 at 20:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.