Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I was running all previous versions of VirtualBox on my Win7 x64 system without any problems. Every upgrade went smoothly, until I tried to upgrade to 4.04 (I can't remember what version I had on the machine previously). At the moment, it is just stuck on the step after it disables network drivers and says it "could take several minutes". Well, I waited over an hour and it still hasn't finished. Cancelling doesn't do anything, so I had to kill the process to get out of the installation.

Does anyone have advice on how to "clean" my system so that I can get VirtualBox running again?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Not useful advice, except that I installed v4.04 on Windows 7 x64 yesterday and it works fine, so it's not fundamentally incompatible.

Do you have anything else in the way of low level networking programs installed - a VPN client, or Wireshark/packet capture, etc.?

The network message could be a red herring, have you tried installing VirtualBox into a different directory, in case it's not liking upgrading something?

share|improve this answer
    
interesting idea regarding the folder location. I'll give that a shot. Yes, I have wireshark installed, but I have always had it on my system through the past version. Thanks! –  Dave Apr 7 '11 at 19:01
    
Here's another data point -- I changed the installation folder, and this time it prompted me to install the Oracle network drivers, which is a good thing. But then it hung immediately afterward. I'll try disabling / removing Wireshark next. Maybe I should check for hidden devices and see if other Oracle network drivers are present in the Device Manager. –  Dave Apr 7 '11 at 19:08
    
and even weirder -- when I clicked on the Start menu to uninstall stuff, I noticed that the VirtualBox icon had magically appeared. Even though I aborted the installation, it finished? WTH? EDIT -- wow, and then when I rebooted my PC, VirtualBox is gone! –  Dave Apr 7 '11 at 19:15
    
This latter issue with the icon appearing and then disappearing is normal behaviour for failed installations, due to artefacts that are lying around until the Windows Installer cleans up. As for the main issue, you may need to remove networking devices like WireShark or Microsoft's Network Monitor (for example), as TessellatingHeckler says. –  user3463 Apr 8 '11 at 3:51
    
TessellatingHeckler had a great suggestion. I removed NetBalancer and Wireshark, and VirtualBox installed fine and is working again. Thanks! –  Dave Apr 8 '11 at 5:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.