Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

As part of my attempts to protect my computer from physical hacking by my client, see enter link description here, I am struggling with Grub2, specifically with how to prevent it from showing the boot menu.

I am trying to prevent the loading of the boot menu, even when the user hits SHIFT key.

1) I've tried disabling 30_os_prober. That doesn't affect the menu.

2) I've tried manually disabling the menu entries, but that just shows less entries and the one that is shown can be edited to provide shell login.

So, any ideas on how to disable the Grub2 boot menu? Any idea would be appriciated

share|improve this question
up vote 1 down vote accepted

Keep the timeout as it is: you may need it sooner or later. And if you boot the PC while keeping the SHIFT key pressed, it is possible that the zero timeout can be circumvented. Rather, password protect the relevant GRUB entries. You may also lock out the recovery modes.

See Ubuntu's fine manual for the details, or this tutorial for the HOWTO.

share|improve this answer

found it.

in the file


add the line

set timeout=0

and the menu won't appear any more.

share|improve this answer
Thanks! Grub2 is a bit of a beast compared to its predecessor. – d11wtq Mar 8 '14 at 7:19

I suppose this would work. The "correct" method would be to directly edit the existing line in /boot/grub/grub.cfg, or even better, change GRUB_TIMEOUT to 0 in /etc/default/grub and remake the config file.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .