Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm on a laptop with Windows XP, and Skype has been giving me weird problems. Whenever I open it up, I have found it auto-selects the wrong microphone input "microphone" instead of front mic, assuming I have a plug-in mic installed (which I never do). Each and every time I open Skype, I have to have my audio deck open and re-select the proper mic.

Not only that, but whenever a call starts it reverts to the plug-in mic selection AGAIN, and I have to select the proper one again, which doesn't always work. I have also found that it changes the mic setting universally and doesn't change it back not even when I exit the program. I've tried to change the setting in Skype options but it only gives me one option for mic anyway, which is, surprisingly, the correct one. What to do?

share|improve this question
    
Your wording is confusing, and it's unclear if 'it' refers to Skype, Windows, or your laptop. So you're saying this problem is not within the settings for Skype, but for the windows audio settings? If so, that is the crux of your problem. Multiple Mics should show up as multiple devices so that Skype can choose among them. –  dlamblin Sep 4 '09 at 22:27
    
You're right, I apologise: It seems that Skype changes the universal windows mic settings. Skype lists one option only for the microphone, while my Audio Deck lists two, from which I am able to select the right one whenever Skype changes to the wrong one. –  surfmadpig Sep 6 '09 at 3:03

4 Answers 4

Do your mics show up under the Device Manager control panel? If so, can you try deleting (or disabling if thats an option) the one you don't want to come up? (Of course that will cause problems if you ever try to plugin a mic, but that doesn't seem to be an issue).

share|improve this answer
    
Rather than deleting it I'd just disable it. –  Col Aug 21 '09 at 7:50
    
only the laptop mic shows up, cause it's the only one I got... so I can't do that. thanks for trying though :) –  surfmadpig Sep 16 '09 at 21:27

If you have more than one mics just go to the Skype. and then Tools -> Options -> Audio settings -> Uncheck 'Automatically adjust Microphone settings' and 'Automatically adjust speaker settings'.

share|improve this answer

I recently started using Skype, and also had a similar problem. Got a Dell Dimension 9150 (Windows XP Home) with onboard SigmaTel Audio, and it has a front mic jack and a rear mic jack.

Its not exactly the same setup as yours, but maybe there are some similarities. (okay, its more than a year ago the questions was asked, but others may stumble upon this.)

Whenever a call in Skype was connected, something in the software/drivers made the rear mic the current input, even though I had beforehand manually selected front mic and the jack was plugged into that one. Quite annoying and strange.

Searching the net, I found on Miguel Carrasco's Real World - "Vista Microphone and Line-In Issues?" a comment by Gopiein dated april 15 2007, which suggested to;

  • go into Control Panel
  • choose SigmaTel Audio
  • activate checkbox Allow Jack Reconfiguration Pop-ups and press OK

After a reboot (maybe not needed), the SigmaTel driver now detects which jack is physically connected, and selects that as the current input. Or line in if neither.

It solved my problem.

share|improve this answer

Go to C:\Documents And Settings\%USERNAME%\Application Data\Skype\%YOUR_USER%\, delete config.xml and reboot Skype.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.