Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a new HP Mini Note running Windows 7 Starter. It mostly stays on the desktop with an external widescreen and whenever I'm not using it I close the lid, thus putting it to sleep.

Now more often than not (but not always) when I next open the lid all my work comes up on the built-in LCD instead of the external monitor and I have to alt-tab to the desktop, right-click on the desktop, choose "Screen resolution", from the "Multiple displays" dropdown select "Show desktop only on 2", then click on OK.

Shouldn't Windows always (rather than just sometimes) remember that it should default to the external monitor? Could it be due to plug-and-play not detecting the external monitor quickly enough? I'm using a VGA connector to a generic (Chimei) 1680x1050 LCD with a "Certified for Windows Vista" sticker.

UPDATE

The answers to this question provide some very convenient workarounds but now my computer often wakes up in the mode where the external monitor and built-in screen are cloned, which still results in my windows being resized. Shortcut to Windows 7 Screen resolution setting other than by right-click on the desktop

share|improve this question
add comment

1 Answer

Hippietrail, can you please try as many as you can of the following and let us know your results?

Does the same problem exist when you plug the same external monitor into another computer and put it into 'sleep' mode?

Does the problem exist when plug another external monitor into you laptop?

Can you connect the problem monitor into your laptop with another type of cable such as A DVI or HDMI?

Thanks

share|improve this answer
    
Hi @super_sonic. I've actually been travelling around the world for the past year with just my netbook and no external monitors, but I will try these suggestions when I get back home (-: –  hippietrail Jun 14 '12 at 9:10
    
Yeah no worries at all - enjoy your trip ;) –  Steve Rathbone Jun 14 '12 at 9:50
    
Well I'm back from my trip and have this problem again! Sadly I don't have another laptop or another monitor to try and the laptop (actually just a netbook) doesn't have HDMI even though the monitor does )-: –  hippietrail Dec 21 '12 at 10:05
    
On my computer (Windows 8, Nvidia GTX 460M) when I shut the lid the programs come back on wake on the main screen. But when I put the computer to sleep without closing the lid the windows remain on the proper displays. That's pretty annoying. –  JohnB Jan 5 at 6:12
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.