Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I tried to install skype on my ubuntu 10.10 resulting in the following error. I even made changes to sources.list adding maverick partner. Still cannot get it to install

  The following packages have unmet dependencies:
     skype : Depends: ia32-libs (>= 20080808) but it is not going to be installed
             Depends: lib32asound2 (> 1.0.22) but it is not going to be installed
             Depends: lib32gcc1 (>= 1:4.1.1) but it is not going to be installed
             Depends: lib32stdc++6 (>= 4.2.1) but it is not going to be installed
             Depends: libc6-i386 (>= 2.4) but it is not going to be installed
    E: Broken packages

When i try to install ia32-libs. This is what i am getting

The following packages have unmet dependencies:
 ia32-libs : Depends: lib32gcc1 but it is not going to be installed
             Depends: libc6-i386 (>= 2.3.6-2) but it is not going to be installed
             Depends: lib32z1 but it is not going to be installed
             Depends: lib32stdc++6 but it is not going to be installed
             Depends: lib32asound2 but it is not going to be installed
             Depends: lib32bz2-1.0 but it is not going to be installed
             Depends: lib32ncurses5 but it is not going to be installed
             Depends: lib32v4l-0 but it is not going to be installed
share|improve this question

migrated from stackoverflow.com Apr 8 '11 at 9:16

This question came from our site for professional and enthusiast programmers.

    
@Abdul this type of question belongs on SuperUser.com or ubuntu.stackexchange. see the faq – David LeBauer Apr 8 '11 at 6:15

What this simply means, you need to download these libraries in order for skype to run properly.

share|improve this answer
    
@The Elite Gentleman when i try to install ia32-libs alone. it's again asking for some dependencies. I even tried installing using deb. it falied too. – Abdul Kader Apr 8 '11 at 6:12
    
@Adbul Kader, yes, you have to make sure that everything you install, if it requires dependencies, install them. That's the beauty of it all. – The Elite Gentleman Apr 8 '11 at 6:13
    
@The Elite Gentleman I tried to install packages one by one. At last stuck at this The following packages have unmet dependencies: libc6-i386 : Depends: libc6 (= 2.11.1-0ubuntu7.8) but 2.12.1-0ubuntu10.2 is to be installed – Abdul Kader Apr 8 '11 at 6:27

Start Synaptic Package Manager and filter for broken packages. Uninstall the broken packages. Reload the software sources. Try installing skype again.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .