Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have tried installing versions 5.5.11 and 5.1.56 of the MySQL Community Server DMG on my new MacBook Pro 2GHz Intel Core i7 running OS X 10.6.6.

It claims that installation is successful, and the Preference Pane window claims that the server is running, but I can't run 'mysql' commands in the Terminal, nor does any MySQL related process show in the Activity Monitor. Can anyone help?

I tried the answer given here, but still no action.

Mysql wont start on Mac OSX?

Thanks in advance, Matt

share|improve this question

migrated from stackoverflow.com Apr 8 '11 at 11:05

This question came from our site for professional and enthusiast programmers.

added these lines into your ~/.bash_profile

If you don't have one, just do vim .bash_profile, hit 'i' to enter insert mode, paste in the lines, hit esc, and type :w (to save) then :q (to quit)

alias mysql='/usr/local/mysql/bin/mysql'

alias mysqladmin='/usr/local/mysql/bin/mysqladmin'

Restart your terminal, and type mysql, that should get you in.

If you dont want to make the alias, try typing ``/usr/local/mysql/bin/mysql into terminal. That should get MySQL running.

share|improve this answer

You must log in to answer this question.