Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Depending on the filetype, firefox shows sometimes a prefix file: (german: 'Datei: '), and sometimes not. Here is a Screenshot: screenshot

I made those dummy-files with linux, and they aren't real files, to check, whether the linux/unix-tool 'file' is involved, which looks at the first bytes of a file to determine what it is - not (so much/at all?) at the extension. Obviously, an extension-lookup is made.

In Unix, anything is a file. So it helps exactly nothing to display the word "file" in front of a file. I like to get rid of that decoration.

How? :)

Update: System is xUbuntu-Linux, Icon-theme: elementaryXubuntu.

A sourceview looks like this:

300: file:///home/stefan/Desktop/kram/test/
200: filename content-length last-modified file-type
201: aaa.jpg 0 Thu,%2021%20Apr%202011%2016:38:02%20GMT FILE 
201: aaa.odt 0 Thu,%2021%20Apr%202011%2016:38:02%20GMT FILE 
201: aaa.pdf 0 Thu,%2021%20Apr%202011%2016:38:02%20GMT FILE 
201: aaa.png 0 Thu,%2021%20Apr%202011%2016:38:02%20GMT FILE 
201: aaa.txt 0 Thu,%2021%20Apr%202011%2016:38:02%20GMT FILE 
201: aaa.xml 0 Thu,%2021%20Apr%202011%2016:38:02%20GMT FILE 

Firefox version is 3.6.16

share|improve this question
    
"Datei:" is in fact the "alternate text" for an image (the filetype icon) that could not be loaded. I don't know how to fix it, though. –  grawity Apr 8 '11 at 15:21
    
Are you on windows or linux? On Ubuntu at least its grabbing the icons from /usr/share/icons/hicolor/16x16/ which I guess might be where you're lacking an icon. –  PriceChild Apr 21 '11 at 10:49
    
If this is indeed related to the web server, and not to the browser (Firefox just handling alt for missing small images differently than some other browsers), then please edit (and above all: retag) your question? (When in doubt, show us a link or a relevant fragment of the HTML you're getting? Or are you using Firefox to browse your local file system?) –  Arjan Apr 21 '11 at 14:45
    
I don't have a webserver running. It's just for viewing file:///home/stefan/ or other directories on the local machine. No HTML involved. –  user unknown Apr 21 '11 at 14:49
    
Instead of 'Datei', you would see 'file' perhaps, and some headlines (Index of file://home/foobar, \n Change to parent directory \n name, size, change-time). I added version (3.6.16) info and sourceview above. –  user unknown Apr 21 '11 at 16:43
add comment

1 Answer

What operating system are you on?

After reading http://rvincent.digital-nerv.net/tag/moz-icon/ I have found that firefox on Ubuntu may use the icons in ~/.icons/Humanity/mimes/ to prettify the pages. There's an example script there of how he fixed a very similar problem (also findable in this post's edit history)

Perhaps trying that would be a good first idea.

I can't figure out where moz-icon:// points to or how its meant to work. Finding out the 'real' name of what's missing, e.g. moz-icon://.BAT?size=16 would probably be a good pointer.

share|improve this answer
    
Thanks. I did so, and for instance, I have icons with pdf in their name, like ./16/application-pdf.png, ./16/gnome-mime-application-pdf.png but no symbol is shown (above screenshot was made on another machine) and I don't have symbols named *odt*, but symbols for odt are shown. System is, btw, xUbuntu-Linux, and Icon-theme, as I found out, is elementaryXubuntu - I include this info above. Last point: Why does the script link to every file, instead of the corresponding directory? Ah, to change the filename form svg to png. That should work? –  user unknown Apr 21 '11 at 14:37
    
That's true... just linking to the 'Humanity' directory would probably be enough.. I'm going to rewrite this answer. –  PriceChild Apr 21 '11 at 15:02
    
I'm sorry, but for the logs: This answer was no solution to the problem. I don't know who voted it up. I don't knwo why the system decides to give it half of the bounty. A silly system, imho. –  user unknown Apr 28 '11 at 5:13
    
@user for reference, here's the Bounty FAQ. If you don't award the bounty it is auto-awarded to the highest voted new answer (with score of at least +2) after the bounty expires - which is what happened here. Unfortunately, nothing can be done to prevent this happening if people have up voted an answer. Using the bounty system does carry some minor risks like this (again, see the FAQ). But! Please note that even with the auto-awarded bounty this answer was not auto-accepted, you still control the tick. –  DMA57361 Apr 28 '11 at 8:15
    
Yes, thank you. I already searched on meta, whether somebody complained about the system, whoms rant I could upvote. I found some related postings but stopped after reading 2 pages of headlines. I noticed, that I could have prevented this from happening (just in this case), if I had downvoted it before from 2 to 1. However it was an attempt to help me, so this would have been a little harsh, no bounty and downvoting. But DV it later and the 25-autobounty value flag it as not the optimal answer, keep a little reward, but not too much - I can live with it, but I don't think the system is ok. –  user unknown Apr 28 '11 at 11:48
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.