Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My on-board audio doesn't work since a long time, so I was using a Skype (official) USB headset. So far so good until it broke (cable cut). After that, I tried a cheap USB sound card (model SJ-588) but after some use, it randomly stops working and I have to reconnect it to get the sound back. That happens in any situation: listening to music, gaming, watching online videos, etc.

So I thought it had to do with that particular USB gadget, and purchased a USB headset (MS LifeChat LX-3000), with the same results.

I'm running Mac OS X 10.6.7, no driver was installed for any of the mentioned gadgets, console logs don't show anything unusual. After I reconnect the USB, it does work again but for a shorter period before it stops again, and so on. Any ideas to fix/troubleshot it?

share|improve this question

4 Answers 4

On my Macbook Pro 13 I've found that turning off airport increases the probability of the usb audio interface (a M-Audio Ozone) actually working for a while. Also, the USB port furthest away from the screen seems better. However, my mileage really varies (two days ago it ran for a full night, tonight it won't run for even a minute) and I've started to suspect my audio interface is broken...

share|improve this answer
    
MATE THANK YOU!!!!!!!! After even plugging simple USB hub without a power, everything works.. I don't know wtf has happend with macbook usb port.. but I tried to restart multiple times, even shutdowning pc... nothing helped.. –  holms Sep 21 '11 at 23:15

After some further googling I came upon a report mentioning that the problem might be the mac usb ports not being able to provide enough power (or current, probably). So, I tried putting a powered usb hub between the Mac and the Ozone which proved successful. It ran the rest of the night without problems.

share|improve this answer

Apple replaced the USB audio driver in Snow Leopard. Unfortunately it is less stable than the old driver and USB audio devices will randomly stop. Most of the time if you pause the application accessing the USB audio device and reselect USB audio in the audio control panel you will regain access to the USB audio device. Rarely will you need to get out of the application and restart it.

This is an issue with OS 10.6.7. I have heard there is a way to step back the driver version, but I don't know what it is. Until Apple releases a patch this is something we will need to live with.

I have tested a raw install of snow leopard on a freshly formatted Hard drive with all updates installed. This was running on a 3GHz 8Core Mac pro with 8GB Ram. Audio was running through 1st generation USB Harmon Kardon Soundsticks. USB audio failed with multiple applications including iTunes, DVD player, QT, and VLC. Content was MP3, MP4, WAV, DVD, AAC, and DV25.

I hope this is helpful. I have submitted a bug report/feedback. The more people who report this issue the more Apple will consider it a legitimate bug and address the issue. I do not know if they have received enough bug reports to troubleshoot the issue.

I suspect the issue might be with how snow leopard is coded to take advantage of idle GPU power for certain tasks. If the USB audio driver was recoded as a result of this that might be where the issue is. But this is only my speculation.

share|improve this answer
1  
I feel compelled to mark this one as the correct answer, since no other thing I've tried gave results (concerning the actual problem, I managed to get sound back using the internal audio board, but no luck through the USB). Do you have any sources to back up your claims? –  fandelost May 10 '11 at 11:54

Open Audio MIDI Setup in Utilities, and change the bitrate from 41k to 48k.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.