Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a remote desktop session to a Windows 7 Workstation that keeps timing out/disconnecting after a minute or two of idiling. Also, sometimes it disconnects while I am in the middle of using it.

I have tried turing off all NIC power saving options, the sound option for remote desktop, and all the go to sleep power saving options. I don't have any issues with remote desktop connecting to various Windows Server 2008 R2 Machines and VMs.

share|improve this question
Is this running on the same LAN or over a NAT or Firewall? – WolfmanJM Apr 8 '11 at 18:07
Gigabit LAN, no NAT or Firewall. – Kyle Brandt Apr 8 '11 at 18:35
Sorry I can't think of anything I was using rdesktop from ubuntu to win7 x64 for quite a while and never encountered that problem, although the mouse cursor issues finally made me give up on rdesktop, – WolfmanJM Apr 8 '11 at 19:22
I am having a go with FreeRDP, so far no timeouts so keeping my fingers crossed. – Kyle Brandt Apr 10 '11 at 19:53

2 Answers 2

Turing off all the checksum offloading options in my Broadcom Driver NIC options solved this issue for me in this case.

It is possible that driver updates might also solve this, but for my use with this laptop I don't really need these features enabled.

share|improve this answer

From this CNET forum post

The machine I was having problem with had RDP enabled from a GPO. In the registry, it had the setting set to have RDP disabled. Everytime gpupdate would run, that registry setting would be come valid and kick me out. Once gpupdate was done running, gpupdate could overwrite that setting and allow me to connect once again. I went into regedit and changed:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Terminal Server entry fDenyTSConnections from 1 to 0, forcing it to always have RDP enabled

To clarify you need to change:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Terminal Server\fDenyTSConnections

from 1 to 0, which it to always have RDP enabled

share|improve this answer
Welcome to Super User! Can you add in the relevant parts of the link into your answer? We ask this to help the OP out, so they will not have to search through information that may not pertain to them. This is also to preserve the relevant information in case the hosting site goes down. For more information, see this meta post. – Cfinley Apr 22 at 19:59
Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. – Mokubai Apr 22 at 20:39

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.