Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have created a shell script for a custom action which is working fine. I want to run this .sh file (mon.sh) on pressing Alt+F15.

I have done the following: In gconf-editor, under apps>metacity>keybinding_commands, edited command_1 with value

"/home/administrator/My Scripts/mon.sh" (tried without quotes also)

under apps>metacity>global_keybindings, edited run_command_1 with value

<Alt>F15

But the script is not getting executed when pressing Alt+F15

What is that I am missing?

share|improve this question
1  
Are you sure the script is able to run properly as a command? Things to check: 1) the interpreter is specified in the first line of the script as #!/path/to/interpreter. 2) the file has the execute bit set for the user (chmod u+x filename). –  Majenko Apr 9 '11 at 15:37
    
Are you actually using Metacity? If window effects are enabled, then you must configure Compiz instead (use ccsm). –  grawity Apr 9 '11 at 20:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.