Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've got a Wireless card (Intel Centrino Advanced-N 6200 AGN) in my Laptop (HP EliteBook 2740p), and from time to time, I lose all wireless network connectivity with the only option to get it back being deactivating and reactivating the network adapter or rebooting the computer. I'm using Windows 7 Pro SP1 64 bit. and the Wifi drivers are up to date.

Any idea?

share|improve this question
add comment

1 Answer 1

up vote 2 down vote accepted

Are you certain the drivers are up to date? We've had exactly the same issue with the same cards. The answer was to go to the Intel website and hunt down the latest drivers. In each case the solved the problem for us. We were running ASUS machines rather than HP but the wireless card was the same. The drivers were the latest that ASUS supplies but Intel does have a newer one. I'd suggest trying out this driver from Intel.

share|improve this answer
    
I'll try that soon, but I can't promise when I get results. I'll get back to you once I do –  private_meta Apr 9 '11 at 15:27
    
Came here to say exactly the same thing as we have had no end of problems with wifi on a number of HP laptops and the fix has been to update the drivers. –  Linker3000 Apr 10 '11 at 17:04
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.