Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running Windows XP Professional SP2.

A few days back I installed xampplite 1.7.1 and was able to access localhost and phpmyadmin through the browser. Today however it suddenly stopped working.

In Firefox after I type http://localhost/ nothing happens - just a blank white screen.

I removed all the files in the xampplite folders and reinstalled ver 1.7.1 again, but it was of no use. I then installed xampplite 1.7.2 (the latest), which I downloaded from the xampp website, but again this made no difference. Apache and MySQL are running however.

I tried using a locally installed WordPress, as I have a theme ready and want to convert that design to WordPress, test it and start using it online.

Running 'Port-check' on xampp control panel showed this:

RESULT
------

Service --     -- Port --      -- Status --
---------------------------------------------------
Apache (HTTP) -- 80 -- C:\xampplite\apache\bin\httpd.exe

Apache (WebDAV) -- 81 -- free

Apache (HTTPS) -- 443 -- C:\xampplite\apache\bin\httpd.exe

MySQL -- 3306 -- C:\xampplite\mysql\bin\mysqld.exe

FileZilla (FTP) -- 21 -- free

FileZilla (Admin) -- 14147 -- free

Mercury (SMTP) -- 25 -- free

Mercury (POP3) -- 110 -- free
Mercury (IMAP) -- 143 -- free

Mercury (HTTP) -- 2224 -- free

Mercury (Finger) -- 79 -- free

Mercury (PH) -- 105 -- free

Mercury (PopPass) -- 106 -- free

Tomcat (AJP/1.3) -- 8009 -- free

Tomcat (HTTP) -- 8080 -- free

---------------------------------------------

I also have Skype installed but it's not using port 80 - I had read this might be the cause of the issue, so I checked under Skype options and confirmed that the port is 65013.

When I run file://C:/xampp/htdocs/index.php it says:

Something is wrong with the XAMPP installation.

Any ideas how I can fix this?

share|improve this question
    
In your C:\xampplite\htdocs folder, make a sample webpage, and try to access it in your browser. –  Breakthrough Aug 20 '09 at 18:13
    
I had copied wordpress files into htdocs folder, also a theme in it, and tried to access the index.php in browser after configuring the necessary file/s. Still not working. –  Sharath kumar Aug 20 '09 at 18:48
    
Check that you don't have a proxy set. Or if you do that "bypass for localhost" is set. –  alumb Aug 21 '09 at 4:48
    
alumb - How do i do that?? –  user7370 Aug 21 '09 at 7:25
    
Assuming you're using ie it's in tools -internet options -connections -lan settings. –  Col Aug 21 '09 at 8:04
show 3 more comments

migrated from stackoverflow.com Aug 21 '09 at 1:49

This question came from our site for professional and enthusiast programmers.

5 Answers

Check your hosts file in %WINDIR%\system32\drivers\etc\hosts and make sure that the following entry is there:

127.0.0.1 localhost
share|improve this answer
add comment

Make sure that Mercury is running, from your port list it doesn't look like it is. That will keep the .php files from opening correctly, it is possible to just see a whitescreen. Make a simple html file and place it in the webservers root and try to access it with local host.

share|improve this answer
    
mercury is a mail server - what's it have to do with PHP? –  Journeyman Geek Aug 22 '11 at 2:11
add comment

You might need to be accessing http://localhost:8080 or some other port. I think 8080 is the default though.

share|improve this answer
add comment

If you really saw a "blank white screen" then the setup is working, i.e. it's not a port problem, because otherwise your browser should give you an error.

You should check the apache configuration files and your document root to see why a blank page is being served.

share|improve this answer
add comment

I often faced trouble with xampp while using skype. Even when it is not running on port 80, you may want to deactivate skype and try again. (a reboot may be required, too)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.