Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I use KeePass2 to access username/password information in a Dropbox file. This allows convenient access from multiple devices. I can't seem to copy a password to the clipboard on my Linux 2.6.27.41-170.2.117.fc10.x86_64 system, however, in order to supply the password to a prompt in an xterm(1). I've tried both Ctrl+C/Ctrl+V and highlighting and mouse button 2 clicking. The KeePass2 program on the Linux system is executed by Mono.

How can I copy the password to the xterm(1)?

[Aside: I think we need a "KeePass" tag.]

ADDENDUM: My mouse buttons were misconfigured: button 2 wasn't set to "copy". Sorry for the false alarm.

share|improve this question

migrated from stackoverflow.com Apr 10 '11 at 10:09

This question came from our site for professional and enthusiast programmers.

    
It's a bit offtopic. Superuser would be better for this. – 0xC0000022L Apr 9 '11 at 16:14
    
In my case, the packages xdotool and xsel did the trick, Source: superuser.com/a/939216/286021 – amenthes Sep 25 '15 at 12:04

Middle mousebutton (probably your scrollbutton) click should work

On two-button mice it would be buttonl+buttonr simultanesously

share|improve this answer
    
I already tried that (highlighting and button 2 clicking). – Steve Emmerson Apr 10 '11 at 16:45

I was experiencing the same issue, not with xterm, but with gnome-terminal in Ubuntu Desktop 11.10.

For me, Ctrl+Shift+Insert works as expected.

Try this with xterm.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .