Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Is the new Ubuntu 11.04 stable enough to install on a macbook partition?

Also, when i attempted to install it, it displayed alot of errors and wouldnt work.

Anyone successfully installed it?

share|improve this question

3 Answers 3

up vote 1 down vote accepted

I have downloaded the beta recently, but not tried it yet. I tried an early pre-release and had no end of trouble with it. I keep meaning to set up a VM to tinker with it.

Maybe that would be the best way for you to go forward with it? VirtualBox is available for OS X, so it would be a good way to see what the stability is like.

Update:

I have now installed it on a VM. It took 2 attempts. The first time, using the normal "Install Ubuntu" startup option hung at formatting the disk. So I went in to the live desktop mode and ran the installer from there - it worked that time.

I can't see very much different to 10.10 - some menus have moved to the top panel (what happens if you don't have a top panel I don't know), and I find that slightly annoying because not all applications have the menus at the top.

However, I couldn't get it to work properly in VB's fullscreen mode, so I installed the guest additions.

Well, everything said it worked, so I rebooted. Once it's back up I find that the top panel has vanished, and the theme has broken. It looks like Gnome 1 with its little gray panel at the bottom...

enter image description here

So for now I'd stay well away from 11.04 for anything other than trying it out. Don't expect it to work too well, because it does seem very shaky.

I think I may be waiting for 11.10 until I upgrade from my stable 10.10 installations.

It seems to me like they have decided to change too much of the internals in one go and had to shoe-horn it together to meet the release deadline of April 2011.

*Update 2:*

I have now been using Ubuntu 11.04 on my live system for some time now and I have come to the following conclusions:

  1. It's completely useless
  2. It's rancidly aweful
  3. It's utter contemptable rubbish.

I am just about to reformat my hard drive and install Mint instead.

My reasons:

Unity is completely useless. It just doesn't work. It's not that it's buggy - I could live with buggy - it's just wrong. The whole idea of it just doesn't work. You are suck with a useless launcher on the left of the screen that you can't do anything with. If you happen to have a screen to the left of you with Synergy you can't even get to the launcher half the time. And those menus at the top of the screen - it's a nice idea and reminds me of the Mac, or the Amiga - but those OSes had it built in at a low level - not tacked on as an extra that just doesn't work at all for some applications.

And as for requiring hardware acceleration to get the required compositing working before you can even press a key - that's just stupid. If your video card isn't one of the best in the world you can just kiss your speed (and even the ability to see what you're doing) goodbye. One of my systems I can't even see the desktop without uninstalling Unity first. It's just a garbled mess of stripes and blocks all over the screen.

So goodbye Ubuntu. It's been nice knowing you.

share|improve this answer
    
wow. what a fantastic answer. I will wait till 11.10 aswell then. thankyou for putting my mind at ease. –  RSM Apr 11 '11 at 8:30
1  
The reason for this is that the X.org server was updated in 11.04 a few weeks ago to a version that isn't yet supported by VirtualBox... you're actually unlikely to have issues with it if installing natively. VirtualBox should have a new release around the time of the official 11.04 release. –  entropo Apr 16 '11 at 17:37

I'm using 11.04 Beta 2 in Macbook (2,1) just fine. Everything works out of the box. I'm installed on a separate partition though (not through VBox).

share|improve this answer

It's because you did not enable the 3D acceleration in VirtualBox. Steps:

Power off the virtual machine

Go to settings

Enable 2D and 3D acceleration

Restart the virtual machine

You get gray menus like the older interface because unity needs 3D acceleration which is not enabled by default in VirtualBox.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.