Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My desktop takes ~5 minutes to resume from sleep. After the long wait it shows the boot screen (text and all) and only then resumes Windows 7. How come? What can I change to speed this up?

Notes:

  • It is a resume from sleep and not from hibernate (I explicitly enter it to sleep and also the resume from hibernate has a filling "resume" bar which resume from sleep doesn't)
  • I know about this SO question, but I believe my situation is different as explained above.
  • The motherboard is Gigabyte GA-965P-DS4 - rev 1.0
share|improve this question
add comment

2 Answers

It sounds as though your computer is in fact failing to resume from sleep (which is why you're seeing the BIOS screen). What is happening is that your computer tries to restore from sleep, fails, and then reboots itself. It then restores your session from the image it saved to disk when you put it to sleep in the first place. (Win7 does much cleverer things with sleep than previous versions.)

This may not be easily soluable. Make sure your Windows is patched to the latest service pack, and if that doesn't help try setting your BIOS options to try the various different ACPI sleep modes.

There are also some settings you can play about with in Windows. Go to "Control Panel", "Power Settings", Select "Change when the computer sleeps" from the left hand side box, then "Change Advanced Power Settings". You can try turning off "USB settings" / "USB Selective Suspend", as your motherboard may not support this. You could also try setting "Sleep" / "Allow hybrid sleep" to off, or if all else fails, set "Sleep" / "Sleep After" to never and "Sleep / Hibernate After" to an appropriate time, and force your machine to hibernate rather than sleep.

Unfortunately suspend and resume have always been pretty flaky, and you may find that your motherboard just doesn't support it that well.

share|improve this answer
    
AFAIK selective suspend occurs not only in sleep, but rather after a timeout of no traffic over the USB, so I don't see how that would be related –  Jonathan Apr 12 '11 at 6:20
add comment

The first thing I would do is make sure your BIOS is up-to-date. Sleep states often are flaky, and they are often improved in BIOS updates.

For your motherboard, the GigaByte GA-965P-DS4 rev 1.0, the latest BIOS version appears to be F12. To determine your current BIOS version, drop to a command prompt and run wmic bios get smbiosbiosversion or you can run Get-WmiObject win32_bios in PowerShell or you can run msinfo32.exe and look at the BIOS Version/Date field.

Next, I would update the drivers for your chipset from the chipset manufacturer. Based on your mobo specs, that appears to be these drivers.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.