Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to create a PDF Form using LibreOffice. I can create the form elements and export as PDF. However, the form fields are giving me problems. The text in these fields always centers on the bottom, and often the text you input is cut off at the bottom.

I found that if I make the fields larger, the text no longer cuts off, but the field is exceptionally large with lots of space above the text.

I have made an odt (source) and a pdf (export) file to show what I'm running into. I tried a number of different fonts and sizes, but to make things easier, I made the field names all "field1" so that once you fill out one entry, all fields show as filled in.

http://ytnoc.net/files/sampleapp.odt
http://ytnoc.net/files/sampleapp.pdf

My main question is how do I make form fields that don't cut off the text without having to make the fields way oversized?

Made with LibreOffice 3.3.0

share|improve this question
    
As an extra note, if I change the default text in LibreOffice so the form is "filled out", it looks ok. It's only when I export it to PDF that the field formatting gets messed up. –  soawesomejohn Apr 10 '11 at 23:34
add comment

6 Answers

This problem appeared when Openoffice upgraded from 2.? to 3.? I suffered the same thing and there wasn't any real solid solution.

I have a work around. Make the field multiline even though it is a single line. This works! :) Maybe later they will improve the PDF exporter.

share|improve this answer
add comment

I am using Libre Office 3.3.3 and found a solution: Border > 'Without frame'. Both '3D look' and 'Flat' result in an inner margin which is overlapping the text.

If the form fields are not visible on Libre Office, then set their background to a color different from the default one (right click the form field/control, then choose Control..., then scroll down to Background).

You can also set the font/size in the same section. I found 8pt Ariel to be about right when viewed in Evince or the Adobe Reader.

A side note - radio buttons don't appear to work in Evince but they are fine in the Adobe Reader.

share|improve this answer
add comment

There are indeed known problems with text inside Fields with PDF Forms generated by OpenOffice/LibreOffice: there is the OpenOffice Bug 114010 about this issue (which was opened in August 2010!). The bug status is set to confirmed, but it isn't targeting a specific OpenOffice release, it may take a while to see it fixed.

It seems there are many small idiosyncrasies between different OO and LO versions on how style defaults are handled, and also wrong behaviors on (default) alignment and font sizes.


There is a basic action that helps across all versions: specifically setting Fields text alignment and a smaller-than-default font size (eg: 8/9pt), something that I noticed while doing some tests on this problem (that I also posted in a comment to the OpenOffice 114010 bug).

It is worth noting Cyrille' solution (at least for Text Fields) works fairly well, if the missing borders are not an issue (if you can set a different background it shouldn't be a problem).

share|improve this answer
    
I wanted to make a link to Cyrille answer but I couldn't because I'm a new user and I can't post more than two links in a message. Sorry! –  Fulvio Jun 15 '12 at 20:07
    
Included the link for you! –  slhck Jun 15 '12 at 21:43
add comment

Open the form in acrobat (or whatever works). Click the form field button. Looks like a simple white rectangle, by default it may be hidden. Look for a button (maybe near advanced editing) that looks like a blue square. It has a dropdown next to it for the other form tools, get the white rectangle.

Double click any of the form boxes. The options for that box pops up. Just change the font from the default (Arial MT) to, say, arial... or any other font. The text now centers properly. I guess either your chosen copy of arial is a little funny, or it's normal but the baseline got adjusted... something that's normally not possible in acrobat forms but might be possible when creating them through a 3rd party program.

share|improve this answer
    
Are you referring to one of the for-pay Adobe Acrobat X Standard/Pro? –  soawesomejohn Apr 11 '11 at 1:17
    
I am, sorry... in my case I have acro pro 7. I guess if you want a cheaper solution, I hear foxit's PDF program can do everything. I haven't tried it with PDF forms. –  CreeDorofl Apr 11 '11 at 2:31
add comment

I am using Libreoffice 3.3.2 . I can't replicate your error, even when I export your odt version to pdf, so I assume that this issue has been resolved in the current version of Libreoffice.

share|improve this answer
add comment

This is NOT fixed in 3.3.2 I'm having the same problem and cannot get text to show up properly in Adobe. This from a form that worked fine last year with Open Office. It was odd - when I edited the form, it said the font in use was (Default) and then if you enter the font setting it's 'Segoe UI'

Setting it directly to Arial has no effect. I'm at a loss on how to make this work.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.