Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I ran without a screensaver for a long time, but recently I enabled one. I set the delay to 10 minutes, but this setting will not hold. It keeps changing to 1 minute.

I am able to apply the 10 minute setting, and I can close and open the Properties dialog and see that the setting is 10 minutes. However, every day at some point I notice that the screensaver comes on after only a minute of inactivity, and when I check the setting it is back to "Wait 1 minutes."

  • I have done a virus and malware scan, and found nothing.

  • I tried a different display driver revision, just in case it might help.

What could be causing this?

Can the screensaver itself change this setting?

Is it possible to "lock" the setting so that programs cannot change it?

I used Process Monitor as recommended, and I found an instance of the setting being changed from 600 to 60 (seconds). The process command was:

"C:\WINDOWS\system32\rundll32.exe" /d C:\WINDOWS\system32\shell32.dll,Control_RunDLL desk.cpl

The only thing I did with desk.cpl during the monitored time was was to turn on and off a second display. This apparently does not happen every time I do this, or it would have happened sooner.

Again, what's causing this, and how do I stop it?

Heptite is also experiencing this problem. He is using Windows 7 (Ultimate, 64-bit) on a laptop.

"Mine was resetting from a value higher than 10 to exactly 10 minutes for a while, but now it's resetting to 1 minute like you're experiencing."

share|improve this question
Are you on a domain with a group policy? – ChrisF Apr 11 '11 at 9:43
@ChrisF this is on my personal machine. I don't recall setting up something like this but anything is possible. How do I check for what you're thinking of? – Mr.Wizard Apr 11 '11 at 9:58
I think you'd remember if you'd set up a domain ;) I'm not on XP at the moment so I can't double check the option you need. – ChrisF Apr 11 '11 at 10:24
I'm seeing mine reset to 10 minutes from any value greater than 10 minutes. Have you been able to discover what's happening? – Heptite Apr 24 '11 at 19:42
I monitored it for a while and saw several more instances of the change as recorded above, but I have not found a way to stop it from happening. Please let me know if you do! – Mr.Wizard Apr 24 '11 at 23:59

Open ProcMon and watch for any Registry operation where Path contains ScreenSaveTimeOut.

You can exclude read operations such as RegOpenKey or RegQueryValue, and only look for writes.

(Edit: fixed value name)

share|improve this answer
I wasn't getting the right stuff at first, but it appears the key name is ScreenSaveTimeOut. I shall monitor that and see if I learn anything. – Mr.Wizard Apr 11 '11 at 7:27

The next step is to go back to Process Monitor and figure out what's launching that rundll32 command.

Filter for Operation Process Create and Path c:\windows\system32\rundll32.exe. That should tell you what process in your system is kicking off the offending setting change.

Once you know which process is at fault, you can take 'corrective action' against the offending program.

share|improve this answer
I have been trying to trace this, but I'm having two problems. First is that I have not been able to properly set up procmon to show me the registry operations for ScreenSaveTimeOut for some reason (probably PEBKAC), which I need to do to verify that my system is getting the setting changed in the same way that @Mr.Wizard's is. The second is that lately I have not been able to reproduce the problem, at all. – Heptite May 6 '11 at 7:03

I am having the same issue on my iMac. I had screensaver set to come on immediately for years. This was fine. But recently, I wanted to set a longer delay. And no matter what I change it to, each day I find it is reset to "immediately". This means I have to keep putting in PW every time the screen saver comes on! I have tried toggling the checkbox; but that does nothing. I even tried leaving the system prefs open indef. Interestingly, when I came in this morning, I noted that the system prefs still said "5 minutes", just as I had left it. But I noticed that the PW was being requested immediately. So I refreshed the Prefs pane (by switching out and back to the "Security & Privacy" settings and, sure enough, the setting had been reset to "immediately"! Very strange. And, so far, despite NUMEROUS attempts over several days, this seems to be the ONLY post I have been able to find where someone else is reporting the same thing. But seems like all of you guys are Windows users. Also doesn't appear that you guys have found a solution.

share|improve this answer
Please don't leave answers stating that you have the same problem as the one described in the question. If you have sufficient reputation, you may upvote the question. Alternatively, "star" it as a favorite and you will be notified of any new answers. – DavidPostill Mar 21 at 18:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .