Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

On my ThinkPad R500 running Windows Vista 64-bit, in the Mouse control panel, I have Vertical Scrolling set to scroll 3 lines per notch, which is the default. At random times, it gets changed to 1 line per notch, and I have to reset it. It usually seems to happen when I'm doing something (i.e., I don't typically come back to the computer after being away and find that it changed while I was gone) but to my knowledge I'm not doing any single thing consistently to make it happen. The problem does not happen on my desktop rig, which is also running Vista 64.

What causes this, and how can I prevent it from happening?

share|improve this question
    
I have this issue in Windows 7 x64 with an HP 8460p laptop. Good job on narrowing it down to suspend/docking. Another possibly related issue superuser.com/questions/289013/… I have seen a lot of threads like this as far back as 2006, but no solution.motherboardpoint.com/… –  Amit Naidu May 10 '13 at 20:20
add comment

2 Answers 2

Notebooks usually have some custom mouse driver, identified by something similar to a Synaptics icon in the taskbar. There is a chance that the said driver may be resetting it randomly.

My recommendation is to get Process Monitor and have it check for changes on "HKCU\Control Panel\Desktop\WheelScrollLines".

share|improve this answer
add comment
up vote 1 down vote accepted

After months of trying to puzzle this out, all I've been able to figure out is that the issue involves the docking process, and only happens when I dock the laptop in sleep/hibernate mode after using it elsewhere. I doubt it's much more solvable than that, and in any event I would expect the problem to go away when I upgrade to Windows 7 anyway.

share|improve this answer
    
There are different profiles for a laptop being docked and not docked. I've seen these (on Dell laptops, at least) get corrupted and doing odd things to system settings (usually network-related). If you right-click on My Computer and choose Properties, on one of the tabs, there is a 'Hardware Profiles' button. If you delete the offending profile, the system will re-create it next time it is made active. That should solve the issue. –  Creepygeek Oct 22 '09 at 17:09
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.