Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

So I've typed into my console:

ln -s "/Applications/Sublime Text 2.app/Contents/SharedSupport/bin/subl" ~/bin/subl

And it says ln Users/myName/bin/subl: Not a directory And I also tried to access it from my finder, and it says: The folder “bin” can’t be opened because you don’t have permission to see its contents. The permission is -rwxr-xr-x@ 1 myName staff 2.2K Mar 5 02:54 bin What should I do? Thanks.

share|improve this question

migrated from stackoverflow.com Apr 11 '11 at 9:59

This question came from our site for professional and enthusiast programmers.

add comment

1 Answer 1

According to that directory listing, bin isn't a directory but a regular file (that's what the first - in -rwxr-xr-x@ indicates). Is it an alias, or something like that? Also, the @ in that listing indicates that it has extended attributes and maybe also an ACL (which can override regular permissions) -- try ls -leO@ ~/bin for more complete info on it.

share|improve this answer
    
-rwxr-xr-x@ 1 myName staff - 2220 Mar 5 02:54 /Users/myName/bin com.apple.quarantine 85 it says.. –  randomor Apr 11 '11 at 3:55
    
@randomor: com.apple.quarantine is an extended attribute indicating that that file came an untrusted (i.e. internet) source. Do you have any idea what is this bin thing is and where it came from? If not, try file ~/bin -- that'll look at the contents and try to figure out what kind of file it is. In any case, I think you'll have to move/rename/delete it, and create a real "bin" folder to replace it. –  Gordon Davisson Apr 11 '11 at 4:52
    
thanks. i've run file ~/bin /Users/myName/bin: POSIX shell script text executable and i renamed it and created a new folder. but still have no idea what that POSIX thing is. But thanks again, you've solved my problem. i thought it is some important folder that i shouldn't mess with. –  randomor Apr 11 '11 at 5:06
2  
@randomor: Try opening it in a text editor. I bet it's a shell script that was supposed to be installed IN ~/bin but instead got installed AS ~/bin. If you can figure out what it is by looking at the text, you can probably rename it appropriately, and put it in ~/bin (after you create that as a folder). –  Gordon Davisson Apr 11 '11 at 6:12
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.