Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm currently having an issue with playing Minecraft. I played Minecraft perfectly before I had an issue with my computer. Now when I open the minecraft.exe file (or try to open Java itself from the start menu) it says there is a problem with Java:

The registry refers to a non-existent Java Runtime Environment installation or the runtime is corrupted. The system cannot find the path specified

I re-installed Java but it seems there is a problem with my windows installer:

"Error 1723. There is a problem with this Windows Installer package. A DLL required for this install to complete could not be run. Contact your support personnel or package vendor."

I tried to reinstall the Windows Installation service however this says there is not enough space (even though I have about 12GB free on my hard drive). I'm not sure if this is the correct file I'm trying to install but I thought it was worth a shot.

share|improve this question

Here's what I did on Windows 7:

Open the registry editor (regedit.exe) using an administrator account.

Go to Computer\HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Runtime Environment

For each version under this path, verify if the paths for the JavaHome and RuntimeLib variables are correct. RuntimeLib should refer to an existent jvm.dll file, JavaHome should be the start of this path with the \bin\client\jvm.dll part removed. For each version of Java you have, you need to do this twice (once for the particular build you have (example 1.7.0_04) and once for the base version (example 1.7). Mine (but take care, I installed to a custom location) are:

  • JavaHome C:\java\jre
  • RuntimeLib C:\java\jre\7\bin\jvm.dll

I got the error because I moved the software to another directory after installation.

share|improve this answer

Try renaming the .exe to a .jar People are having this same issue and this seems to solve it.

Once you've tried that, remove every instance of Java you have and reinstall with a package from Java's website. Make sure it's the right architecture (32-64 bit). Try removing Java with the Windows Cleanup Utility, then reboot, the reinstall.

EDIT: Come to think of it, back when I ran windows a similar thing happened to me. Try upgrading to the latest version of Windows Installer. If you're already at the latest, try reinstalling.

share|improve this answer
I feel the problem may be deeper with Java as .jar files aren't even associated with Java anymore (it doesn't know what to open them with). Any ideas? – Leon Apr 11 '11 at 11:17
I just edited my answer, try that. If not, we'll keep looking. – n0pe Apr 11 '11 at 11:18
Trying to install the Windows Installer redist gives the error "Not enough storage is available to process this command". As for uninstalling Java via the Windows Cleanup Utility, the uninstall worked and I'm trying to reinstall Java now (just at the bit where it usually errors - we'll see). – Leon Apr 11 '11 at 11:26
Alright let's hope you don't encounter errors – n0pe Apr 11 '11 at 11:29
Unfortunately when trying to install Java, it thinks it already has it installed. I click reinstall but then it says "This action is only valid for products that are currently installed". It's really just smacking itself in the face. Any ideas? (Just restarted - still have the same problem) – Leon Apr 11 '11 at 11:34

My workstation is Win 7 64 bit.

Solution for me was to change all references of

C:\Program Files\Java\...


C:\Program Files (x86)\Java\...

in the registry path


My actual installed path and registry entries did not match.

share|improve this answer

You must log in to answer this question.

protected by Community Mar 3 '15 at 12:17

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .