Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My Windows XP SP3 machine freezes when scratched or non-standard optical media are inserted during the boot sequence.

It seems that the system tries to preload some data from the CD, and when it fails at that, it simply hangs up.

Is there any way to prevent such behavior? I do not mean autostart. This is a completely different thing. It seems that even when autostart is switched off, XP wants some data from every optical medium that is inserted into the computer at boot time. Is there any way to stop this from happening?

share|improve this question

3 Answers 3

up vote 1 down vote accepted

Short Answer: Don't use scratched/damaged media.

Long Answer with more details: During boot, Windows has not yet switched to a multi-threaded environment. If any one piece decides to not run asynchronous, the entire boot-process will stall until either A) the process completes or B) windows decides to kill the process. In the case of a CD-Rom drive... it is treated as a device like any-other with a driver, and when that driver is loaded, the first thing it does is query what's in the drive. Unfortunately, this is not an asynchronous process. The CD-ROM drive waits for the drive to return some information about what's inside blocking all other execution of code during the boot-process. Luckily, Windows doesn't get to kill it (or you would end up with a BSOD), but rather the driver has some spiffy logistics in it to stop asking what is in the drive after some period of time. (not exactly sure what that time is) Once windows has finished booting, it switches to a multi-threaded environment which is why the CD-ROM doesn't lock up the whole machine while waiting for the results to come back.

Additionally... prior to the actual "Windows Boot" your BIOS may have some sort of firmware-recovery that can try & access your CD-ROM which is also not running in a multi-threaded environment and suffers from the same "wait for the drive to say something" type problems.

share|improve this answer

You could try disabling boot from optical drive in your BIOS.

share|improve this answer
    
Or move it down the boot device list, make the hard drive first, optical second. –  Moab Apr 11 '11 at 20:36

My gut reaction to this is "well, don't insert damaged or non-standard media at boot time." Computers running many OSes will try to read from the optical drive at boot time in case you're trying to, well, boot from it. (This can be a very useful feature when you're trying to repair, say, a corrupted OS.)

That said, if you feel like that's not an option for you, could you explain what you're trying to achieve? It may help us get you a better answer.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.