Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I got a Dell Inspiron 1501 (one of the AMD based models, circa June 2007) that I reinstalled Windows on, and now have wireless connection issues.

The rundown, I installed a fresh copy of Windows XP Pro with SP3, and downloaded all of the drivers that Dell recommended based on the service tag, then ran Windows Update and brought everything up to date. Wired networking works fine (and is how I ran Windows Update).

When I try to use the Windows wireless tool, it will display the network, and allow you to connect to it (either prompting for the key or reminding you that the network is insecure). Once it starts connecting, the wireless tool says "scanning for networks" for a few seconds, then comes back with "no networks found" and will not redisplay the network you tried connecting to.

The wireless card is a BCM4311, and the routers I've been connecting to are varying models of Linksys (a WRT54GLv1.1 with OpenWRT with no encryption, a newer N band Linksys with WPA-PSK2, and an older access point only model with no encryption). Other devices can connect to all three networks fine.

There are no entries in the event logs about this that I can find.

I am really stumped and more then happy to edit the question with any additional information anyone wants.

share|improve this question
    
Did the wireless ever work well? Before the install? Any history on this Dell? –  Moab Apr 12 '11 at 2:49
    
ugh, I messed up my StackExchange login... I couldn't get a stable connection in Linux (tried STA, b43, and ndiswrapper, long association time, followed by an authentication time out, or thats how I interpreted the syslog entries) so I tried Windows thinking it was the usual Broadcom tom-foolery. –  mwalling Apr 12 '11 at 12:11
add comment

1 Answer

Did WU install a new driver for the wireless card? In that case I would suggest reinstalling an official Broadcom driver.

share|improve this answer
    
No, the only hardware driver that it offered to install was related to the modem, and I ignored it. –  mwalling Apr 11 '11 at 23:38
    
Since WPA2 has only been introduced in SP3, it might be worth trying to upgrade to a more recent driver anyway. This one should work: drivers.softpedia.com/progDownload/… –  plco Apr 11 '11 at 23:48
    
But there are two unprotected networks that it doesn't work on, in addition to the one WPA2 network. The driver installed is the latest driver offered by Dell for that machine, and I have all of the KBs from Microsoft installed (including SP3, which includes KB893357). –  mwalling Apr 11 '11 at 23:49
    
Sorry, what I meant is the Wireless stack has been updated in SP3, and the driver you have downloaded is from 2007 (pre-SP3). –  plco Apr 11 '11 at 23:57
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.