Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

All in the question. Apple's installer whines I'm using the wrong one with 32bit and that I'm not using Vista or 7 with 64bit.

share|improve this question
2  
XP64 will never be officially supported by anyone. What do the notices that the installers give you when they install? Do they not let you or do they just notify you? –  MaQleod Apr 12 '11 at 6:00
    
@magleod "Your OS is the wrong one, click ok to continue" type of stuff –  Andrew G. Johnson Apr 12 '11 at 8:57
add comment

2 Answers

You can install the package by bypassing the unnecessary artificial restriction preventing installation in XP x64. Use 7zip to extract the files in the install package.

The complaint is from the SetupAdmin.exe file that simply invokes the msi files. You don't need to use this file, it provides one-click installation. You can install the component MSI files individually...

... except the iTunes64.msi because it is marked to restrict the file to OS versions that correspont to Vista or later. Use an MSI file editor (Microsoft's Orca MSI editor is free) to set the restriction to an OS version corresponding to XP x64 or later to allow the file to install.

For step by step instructions see the guide at; http://skunkwerks.wordpress.com/2008/04/13/getting-itunes-to-work-with-windows-xp-x64/

From a Google search it seems that some iTunes versions complain on startup that they are incorrectly installed on XP x64, and then operate correctly anyway. The message is harmless albeit annoying but reinstalling does not resolve the issue.

share|improve this answer
add comment

first make sure you have sp3. (the following worked for me on a x64 vista platform.) there are two program files folders in a x64 system. the x86 for 32-bit apps and the x64. generally you're better off with the 32-bit v and make sure it gets installed in the correct folder. also check the compatibility - right click on the itunes .exe file and select properties from the bottom of drop down list - 3rd tab should be it - select the xp w/sp3 mode. you might have to play with it here and there as there are not many apps that are coded exclusivey for a x64 environment and then you have the apple v windows issue. if possible ($$$) and hw permitting go w/win 7 for the w.

share|improve this answer
4  
Awful, awful answer. XP x64 doesn't have an SP3, most recent is SP2. Then you start saying how things worked for you on Vista 64. Vista 64 is officially supported by Apple, I'm assuming next, next, I accept, finish would have worked just as well. –  Andrew G. Johnson Apr 12 '11 at 8:59
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.